Hacktoberfest 2026: le issue che i maintainer hanno segnato per ottobre, aperte e adatte ai principianti. Sfoglia le issue Hacktoberfest

Proprietario

python-caldav

1 repository indicizzato · Vedi su GitHub

Caricamento delle issue

Le issue su cui forse qualcuno sta già lavorando sono in fondo alla lista. Ordina tutto per data

  • Todo.complete(rrule_mode="this_and_future") raises AttributeError; only the undeclared "thisandfuture" works
    Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 66/100

    python-caldav/caldav#735 ·

    I maintainer di solito rispondono entro 1 giorno

  • Tests: It's needed with some test-runs without `features` configured
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 48/100

    python-caldav/caldav#725 ·

    I maintainer di solito rispondono entro 1 giorno

  • Test the library properly with Yahoo
    Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 48/100

    python-caldav/caldav#720 ·

    I maintainer di solito rispondono entro 1 giorno

  • Credentials are never sent to servers that omit WWW-Authenticate on 401 (e.g. Yahoo Calendar)
    Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 62/100

    python-caldav/caldav#713 · 5 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Configuration: allow password-yielding commands in config file.
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 30/100

    python-caldav/caldav#704 ·

    I maintainer di solito rispondono entro 1 giorno

  • Extended MKCOL (RFC 5689): detection, testing and 207 handling
    Aperta
    enhancement roadmap

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 45/100

    python-caldav/caldav#702 ·

    I maintainer di solito rispondono entro 1 giorno

  • Support calendar sharing (draft-pot-caldav-sharing)
    Aperta
    enhancement roadmap

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#701 ·

    I maintainer di solito rispondono entro 1 giorno

  • Support managed attachments (RFC 8607)
    Aperta
    enhancement roadmap

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#700 ·

    I maintainer di solito rispondono entro 1 giorno

  • Implement WebDAV ACL operations on calendars (RFC 3744)
    Aperta
    enhancement roadmap

    Difficoltà 5/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#699 ·

    I maintainer di solito rispondono entro 1 giorno

  • Parse server iCalendar through vcal.parse_ical() consistently
    Aperta
    refactoring

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 48/100

    python-caldav/caldav#698 ·

    I maintainer di solito rispondono entro 1 giorno

  • Rate-limit handling to count requests
    Aperta
    enhancement

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 35/100

    python-caldav/caldav#697 ·

    I maintainer di solito rispondono entro 1 giorno

  • Sync mode support for the httpx family
    Aperta
    enhancement

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 32/100

    python-caldav/caldav#696 ·

    I maintainer di solito rispondono entro 1 giorno

  • Retries on connection failures and on a closed idle keep-alive connection
    Aperta
    enhancement

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 38/100

    python-caldav/caldav#695 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • require_tls only enforced on RFC 6764 discovery, not on explicit URLs
    Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 62/100

    python-caldav/caldav#687 ·

    I maintainer di solito rispondono entro 1 giorno

  • AssertionError ("Deviation from expectations found") when using Infomaniak CalDAV with Home Assistant Container
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 38/100

    python-caldav/caldav#684 · 5 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Cannot download
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    python-caldav/caldav#680 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • WebDAV Push support
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 30/100

    python-caldav/caldav#674 · 4 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Async refactoring: reduce code duplication
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 32/100

    python-caldav/caldav#665 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • "Protocol layer" cleanup
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#664 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • FeatureSet cleanup: simplify over-complex type-system remnants in compatibility_hints.py
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 45/100

    python-caldav/caldav#659 ·

    I maintainer di solito rispondono entro 1 giorno

  • Ruff ignore list is too long
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#634 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • GMX calendar creation not working very well
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    python-caldav/caldav#624 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • v4.0 - rip out all deprecated methods that yields deprecationwarning
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#619 ·

    I maintainer di solito rispondono entro 1 giorno

  • is it better to create new DAVClients or reuse one DAVClient for long-term repeated syncing tasks?
    Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 30/100

    python-caldav/caldav#612 · 3 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Auto-detection of server quirks
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 28/100

    python-caldav/caldav#600 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • Roadmap Updates
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    python-caldav/caldav#599 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Intelligent deletion of single recurrences
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#598 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Create helper methods for identifying various "recurrence states" for a CalendarObjectResource
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    python-caldav/caldav#597 ·

    I maintainer di solito rispondono entro 1 giorno

  • Refactor setup/teardown methods in the functional test setup
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#593 ·

    I maintainer di solito rispondono entro 1 giorno

  • Feature configuration subsystem: extra_features and include
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#592 ·

    I maintainer di solito rispondono entro 1 giorno

  • Remove the old incompatibility flags completely
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#585 ·

    I maintainer di solito rispondono entro 1 giorno

  • `tests/conf.py` is a mess
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    python-caldav/caldav#577 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • Support negated searches
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#568 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • Improved collation support for non-ascii case-insensitive text-match
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#567 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

  • Follow PROPFIND redirects
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#552 · 3 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Searching also returns full-day events of adjacent days
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 48/100

    python-caldav/caldav#545 · 6 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Docs and example code: use the icalendar .new method
    Aperta
    doc

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 42/100

    python-caldav/caldav#541 · 3 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Find and kill instances of `event.component['uid']` et al
    Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 35/100

    python-caldav/caldav#515 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Documentation howtos
    Aperta
    doc

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 35/100

    python-caldav/caldav#513 ·

    I maintainer di solito rispondono entro 1 giorno

  • Support RFC 7953 Availability
    Aperta
    enhancement

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 35/100

    python-caldav/caldav#425 ·

    I maintainer di solito rispondono entro 1 giorno

  • Improvements, test code and documentation needed for editing and selecting recurrence instances
    Aperta
    doc

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    python-caldav/caldav#398 · 4 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Collission avoidance
    Aperta
    enhancement

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 45/100

    python-caldav/caldav#152 ·

    I maintainer di solito rispondono entro 1 giorno

  • Support for alarms
    Aperta
    enhancement

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 35/100

    python-caldav/caldav#132 · 6 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Documentation for each server/cloud provider
    Aperta
    doc enhancement

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    python-caldav/caldav#120 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • object.id should always work
    Aperta
    refactoring

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 35/100

    python-caldav/caldav#94 · 4 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Increase test coverage
    Aperta
    testing regime

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    python-caldav/caldav#93 · 3 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • calendar.add_event can update as well
    Aperta
    bug

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 35/100

    python-caldav/caldav#71 · 8 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • Caldav test servers
    Aperta
    help wanted roadmap testing regime

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 18/100

    python-caldav/caldav#45 · 20 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • iCloud: URL.join raises "can't be joined" when REPORT hrefs use caldav.icloud.com after client.url was rewritten to the pNN partition host
    Forse già presa @tobixen l’ha presa oggi. Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 52/100

    python-caldav/caldav#730 · 2 commenti ·

    I maintainer di solito rispondono entro 1 giorno

  • change_attendee_status() not completely async safe
    Forse già presa Una pull request collegata a questa issue è aperta o già unita. Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 48/100

    python-caldav/caldav#678 · 1 commento ·

    I maintainer di solito rispondono entro 1 giorno

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.