Hacktoberfest 2026 : les issues que les mainteneurs ont marquées pour octobre, ouvertes et accessibles aux débutants. Parcourir les issues Hacktoberfest

Propriétaire

1 dépôt indexé · Voir sur GitHub

Les issues sur lesquelles quelqu’un travaille peut-être déjà sont listées en dernier. Tout trier par date

  • Todo.complete(rrule_mode="this_and_future") raises AttributeError; only the undeclared "thisandfuture" works
    Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 66/100

    python-caldav/caldav#735 ·

    Les mainteneurs répondent en général sous 1 jour

  • Tests: It's needed with some test-runs without `features` configured
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 48/100

    python-caldav/caldav#725 ·

    Les mainteneurs répondent en général sous 1 jour

  • Test the library properly with Yahoo
    Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 48/100

    python-caldav/caldav#720 ·

    Les mainteneurs répondent en général sous 1 jour

  • Credentials are never sent to servers that omit WWW-Authenticate on 401 (e.g. Yahoo Calendar)
    Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 62/100

    python-caldav/caldav#713 · 5 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Configuration: allow password-yielding commands in config file.
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 30/100

    python-caldav/caldav#704 ·

    Les mainteneurs répondent en général sous 1 jour

  • Extended MKCOL (RFC 5689): detection, testing and 207 handling
    Ouverte
    enhancement roadmap

    Difficulté 4/5 3-5 jours Accessibilité débutants 45/100

    python-caldav/caldav#702 ·

    Les mainteneurs répondent en général sous 1 jour

  • Support calendar sharing (draft-pot-caldav-sharing)
    Ouverte
    enhancement roadmap

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#701 ·

    Les mainteneurs répondent en général sous 1 jour

  • Support managed attachments (RFC 8607)
    Ouverte
    enhancement roadmap

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#700 ·

    Les mainteneurs répondent en général sous 1 jour

  • Implement WebDAV ACL operations on calendars (RFC 3744)
    Ouverte
    enhancement roadmap

    Difficulté 5/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#699 ·

    Les mainteneurs répondent en général sous 1 jour

  • Parse server iCalendar through vcal.parse_ical() consistently
    Ouverte
    refactoring

    Difficulté 4/5 3-5 jours Accessibilité débutants 48/100

    python-caldav/caldav#698 ·

    Les mainteneurs répondent en général sous 1 jour

  • Rate-limit handling to count requests
    Ouverte
    enhancement

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 35/100

    python-caldav/caldav#697 ·

    Les mainteneurs répondent en général sous 1 jour

  • Sync mode support for the httpx family
    Ouverte
    enhancement

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 32/100

    python-caldav/caldav#696 ·

    Les mainteneurs répondent en général sous 1 jour

  • Retries on connection failures and on a closed idle keep-alive connection
    Ouverte
    enhancement

    Difficulté 4/5 3-5 jours Accessibilité débutants 38/100

    python-caldav/caldav#695 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • require_tls only enforced on RFC 6764 discovery, not on explicit URLs
    Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 62/100

    python-caldav/caldav#687 ·

    Les mainteneurs répondent en général sous 1 jour

  • AssertionError ("Deviation from expectations found") when using Infomaniak CalDAV with Home Assistant Container
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 38/100

    python-caldav/caldav#684 · 5 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Cannot download
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    python-caldav/caldav#680 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • WebDAV Push support
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 30/100

    python-caldav/caldav#674 · 4 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Async refactoring: reduce code duplication
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 32/100

    python-caldav/caldav#665 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • "Protocol layer" cleanup
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#664 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • FeatureSet cleanup: simplify over-complex type-system remnants in compatibility_hints.py
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 45/100

    python-caldav/caldav#659 ·

    Les mainteneurs répondent en général sous 1 jour

  • Ruff ignore list is too long
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#634 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • GMX calendar creation not working very well
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    python-caldav/caldav#624 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • v4.0 - rip out all deprecated methods that yields deprecationwarning
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#619 ·

    Les mainteneurs répondent en général sous 1 jour

  • is it better to create new DAVClients or reuse one DAVClient for long-term repeated syncing tasks?
    Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 30/100

    python-caldav/caldav#612 · 3 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Auto-detection of server quirks
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 28/100

    python-caldav/caldav#600 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • Roadmap Updates
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    python-caldav/caldav#599 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Intelligent deletion of single recurrences
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#598 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Create helper methods for identifying various "recurrence states" for a CalendarObjectResource
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    python-caldav/caldav#597 ·

    Les mainteneurs répondent en général sous 1 jour

  • Refactor setup/teardown methods in the functional test setup
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#593 ·

    Les mainteneurs répondent en général sous 1 jour

  • Feature configuration subsystem: extra_features and include
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#592 ·

    Les mainteneurs répondent en général sous 1 jour

  • Remove the old incompatibility flags completely
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#585 ·

    Les mainteneurs répondent en général sous 1 jour

  • `tests/conf.py` is a mess
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    python-caldav/caldav#577 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • Support negated searches
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#568 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • Improved collation support for non-ascii case-insensitive text-match
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#567 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

  • Follow PROPFIND redirects
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#552 · 3 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Searching also returns full-day events of adjacent days
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 48/100

    python-caldav/caldav#545 · 6 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Docs and example code: use the icalendar .new method
    Ouverte
    doc

    Difficulté 3/5 1-2 jours Accessibilité débutants 42/100

    python-caldav/caldav#541 · 3 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Find and kill instances of `event.component['uid']` et al
    Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 35/100

    python-caldav/caldav#515 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Documentation howtos
    Ouverte
    doc

    Difficulté 3/5 1-2 jours Accessibilité débutants 35/100

    python-caldav/caldav#513 ·

    Les mainteneurs répondent en général sous 1 jour

  • Support RFC 7953 Availability
    Ouverte
    enhancement

    Difficulté 3/5 1-2 jours Accessibilité débutants 35/100

    python-caldav/caldav#425 ·

    Les mainteneurs répondent en général sous 1 jour

  • Improvements, test code and documentation needed for editing and selecting recurrence instances
    Ouverte
    doc

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    python-caldav/caldav#398 · 4 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Collission avoidance
    Ouverte
    enhancement

    Difficulté 3/5 1-2 jours Accessibilité débutants 45/100

    python-caldav/caldav#152 ·

    Les mainteneurs répondent en général sous 1 jour

  • Support for alarms
    Ouverte
    enhancement

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 35/100

    python-caldav/caldav#132 · 6 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Documentation for each server/cloud provider
    Ouverte
    doc enhancement

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    python-caldav/caldav#120 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • object.id should always work
    Ouverte
    refactoring

    Difficulté 3/5 1-2 jours Accessibilité débutants 35/100

    python-caldav/caldav#94 · 4 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Increase test coverage
    Ouverte
    testing regime

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    python-caldav/caldav#93 · 3 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • calendar.add_event can update as well
    Ouverte
    bug

    Difficulté 3/5 1-2 jours Accessibilité débutants 35/100

    python-caldav/caldav#71 · 8 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • Caldav test servers
    Ouverte
    help wanted roadmap testing regime

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 18/100

    python-caldav/caldav#45 · 20 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • iCloud: URL.join raises "can't be joined" when REPORT hrefs use caldav.icloud.com after client.url was rewritten to the pNN partition host
    Peut-être pris @tobixen l’a pris aujourd’hui. Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 52/100

    python-caldav/caldav#730 · 2 commentaires ·

    Les mainteneurs répondent en général sous 1 jour

  • change_attendee_status() not completely async safe
    Peut-être pris Une pull request liée à cette issue est ouverte ou déjà fusionnée. Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 48/100

    python-caldav/caldav#678 · 1 commentaire ·

    Les mainteneurs répondent en général sous 1 jour

Recevez les nouvelles issues par e-mail

Un résumé court des issues GitHub adaptées aux débutants.