Hacktoberfest 2026: los issues que los mantenedores marcaron para octubre, abiertos y aptos para principiantes. Explorar issues de Hacktoberfest

Propietario

1 repositorio indexado · Ver en GitHub

Las issues en las que quizá ya trabaja alguien aparecen al final. Ordenar todo por fecha

  • Todo.complete(rrule_mode="this_and_future") raises AttributeError; only the undeclared "thisandfuture" works
    Abierto

    Dificultad 2/5 1-3 horas Aptitud para principiantes 66/100

    python-caldav/caldav#735 ·

    Los mantenedores suelen responder en 1 día

  • Tests: It's needed with some test-runs without `features` configured
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 48/100

    python-caldav/caldav#725 ·

    Los mantenedores suelen responder en 1 día

  • Test the library properly with Yahoo
    Abierto

    Dificultad 3/5 1-2 días Aptitud para principiantes 48/100

    python-caldav/caldav#720 ·

    Los mantenedores suelen responder en 1 día

  • Credentials are never sent to servers that omit WWW-Authenticate on 401 (e.g. Yahoo Calendar)
    Abierto

    Dificultad 3/5 1-2 días Aptitud para principiantes 62/100

    python-caldav/caldav#713 · 5 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Configuration: allow password-yielding commands in config file.
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 30/100

    python-caldav/caldav#704 ·

    Los mantenedores suelen responder en 1 día

  • Extended MKCOL (RFC 5689): detection, testing and 207 handling
    Abierto
    enhancement roadmap

    Dificultad 4/5 3-5 días Aptitud para principiantes 45/100

    python-caldav/caldav#702 ·

    Los mantenedores suelen responder en 1 día

  • Support calendar sharing (draft-pot-caldav-sharing)
    Abierto
    enhancement roadmap

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#701 ·

    Los mantenedores suelen responder en 1 día

  • Support managed attachments (RFC 8607)
    Abierto
    enhancement roadmap

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#700 ·

    Los mantenedores suelen responder en 1 día

  • Implement WebDAV ACL operations on calendars (RFC 3744)
    Abierto
    enhancement roadmap

    Dificultad 5/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#699 ·

    Los mantenedores suelen responder en 1 día

  • Parse server iCalendar through vcal.parse_ical() consistently
    Abierto
    refactoring

    Dificultad 4/5 3-5 días Aptitud para principiantes 48/100

    python-caldav/caldav#698 ·

    Los mantenedores suelen responder en 1 día

  • Rate-limit handling to count requests
    Abierto
    enhancement

    Dificultad 5/5 Más de una semana Aptitud para principiantes 35/100

    python-caldav/caldav#697 ·

    Los mantenedores suelen responder en 1 día

  • Sync mode support for the httpx family
    Abierto
    enhancement

    Dificultad 5/5 Más de una semana Aptitud para principiantes 32/100

    python-caldav/caldav#696 ·

    Los mantenedores suelen responder en 1 día

  • Retries on connection failures and on a closed idle keep-alive connection
    Abierto
    enhancement

    Dificultad 4/5 3-5 días Aptitud para principiantes 38/100

    python-caldav/caldav#695 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • require_tls only enforced on RFC 6764 discovery, not on explicit URLs
    Abierto

    Dificultad 2/5 1-3 horas Aptitud para principiantes 62/100

    python-caldav/caldav#687 ·

    Los mantenedores suelen responder en 1 día

  • AssertionError ("Deviation from expectations found") when using Infomaniak CalDAV with Home Assistant Container
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 38/100

    python-caldav/caldav#684 · 5 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Cannot download
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    python-caldav/caldav#680 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • WebDAV Push support
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 30/100

    python-caldav/caldav#674 · 4 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Async refactoring: reduce code duplication
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 32/100

    python-caldav/caldav#665 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • "Protocol layer" cleanup
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#664 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • FeatureSet cleanup: simplify over-complex type-system remnants in compatibility_hints.py
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 45/100

    python-caldav/caldav#659 ·

    Los mantenedores suelen responder en 1 día

  • Ruff ignore list is too long
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#634 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • GMX calendar creation not working very well
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    python-caldav/caldav#624 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • v4.0 - rip out all deprecated methods that yields deprecationwarning
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#619 ·

    Los mantenedores suelen responder en 1 día

  • is it better to create new DAVClients or reuse one DAVClient for long-term repeated syncing tasks?
    Abierto

    Dificultad 2/5 1-3 horas Aptitud para principiantes 30/100

    python-caldav/caldav#612 · 3 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Auto-detection of server quirks
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 28/100

    python-caldav/caldav#600 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • Roadmap Updates
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 20/100

    python-caldav/caldav#599 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Intelligent deletion of single recurrences
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#598 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Create helper methods for identifying various "recurrence states" for a CalendarObjectResource
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    python-caldav/caldav#597 ·

    Los mantenedores suelen responder en 1 día

  • Refactor setup/teardown methods in the functional test setup
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#593 ·

    Los mantenedores suelen responder en 1 día

  • Feature configuration subsystem: extra_features and include
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#592 ·

    Los mantenedores suelen responder en 1 día

  • Remove the old incompatibility flags completely
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#585 ·

    Los mantenedores suelen responder en 1 día

  • `tests/conf.py` is a mess
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    python-caldav/caldav#577 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • Support negated searches
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#568 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • Improved collation support for non-ascii case-insensitive text-match
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#567 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

  • Follow PROPFIND redirects
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#552 · 3 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Searching also returns full-day events of adjacent days
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 48/100

    python-caldav/caldav#545 · 6 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Docs and example code: use the icalendar .new method
    Abierto
    doc

    Dificultad 3/5 1-2 días Aptitud para principiantes 42/100

    python-caldav/caldav#541 · 3 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Find and kill instances of `event.component['uid']` et al
    Abierto

    Dificultad 3/5 1-2 días Aptitud para principiantes 35/100

    python-caldav/caldav#515 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Documentation howtos
    Abierto
    doc

    Dificultad 3/5 1-2 días Aptitud para principiantes 35/100

    python-caldav/caldav#513 ·

    Los mantenedores suelen responder en 1 día

  • Support RFC 7953 Availability
    Abierto
    enhancement

    Dificultad 3/5 1-2 días Aptitud para principiantes 35/100

    python-caldav/caldav#425 ·

    Los mantenedores suelen responder en 1 día

  • Improvements, test code and documentation needed for editing and selecting recurrence instances
    Abierto
    doc

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    python-caldav/caldav#398 · 4 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Collission avoidance
    Abierto
    enhancement

    Dificultad 3/5 1-2 días Aptitud para principiantes 45/100

    python-caldav/caldav#152 ·

    Los mantenedores suelen responder en 1 día

  • Support for alarms
    Abierto
    enhancement

    Dificultad 5/5 Más de una semana Aptitud para principiantes 35/100

    python-caldav/caldav#132 · 6 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Documentation for each server/cloud provider
    Abierto
    doc enhancement

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    python-caldav/caldav#120 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • object.id should always work
    Abierto
    refactoring

    Dificultad 3/5 1-2 días Aptitud para principiantes 35/100

    python-caldav/caldav#94 · 4 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Increase test coverage
    Abierto
    testing regime

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    python-caldav/caldav#93 · 3 comentarios ·

    Los mantenedores suelen responder en 1 día

  • calendar.add_event can update as well
    Abierto
    bug

    Dificultad 3/5 1-2 días Aptitud para principiantes 35/100

    python-caldav/caldav#71 · 8 comentarios ·

    Los mantenedores suelen responder en 1 día

  • Caldav test servers
    Abierto
    help wanted roadmap testing regime

    Dificultad 5/5 Más de una semana Aptitud para principiantes 18/100

    python-caldav/caldav#45 · 20 comentarios ·

    Los mantenedores suelen responder en 1 día

  • iCloud: URL.join raises "can't be joined" when REPORT hrefs use caldav.icloud.com after client.url was rewritten to the pNN partition host
    Posiblemente ocupada @tobixen la tomó hoy. Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 52/100

    python-caldav/caldav#730 · 2 comentarios ·

    Los mantenedores suelen responder en 1 día

  • change_attendee_status() not completely async safe
    Posiblemente ocupada Un pull request vinculado a esta issue está abierto o ya se fusionó. Abierto

    Dificultad 3/5 1-2 días Aptitud para principiantes 48/100

    python-caldav/caldav#678 · 1 comentario ·

    Los mantenedores suelen responder en 1 día

Recibe los nuevos issues en tu correo

Un resumen breve de issues de GitHub para principiantes.