Hacktoberfest 2026: as issues que os mantenedores marcaram para outubro, abertas e boas para iniciantes. Ver issues do Hacktoberfest

Proprietário

python-caldav

1 repositório indexado · Ver no GitHub

Carregando issues

Issues em que talvez alguém já esteja trabalhando aparecem no fim. Ordenar tudo por data

  • save() increments SEQUENCE by default - wrong for sync and copy use cases
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    python-caldav/caldav#739 ·

    Mantenedores costumam responder em até 1 dia

  • Tests: It's needed with some test-runs without `features` configured
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 48/100

    python-caldav/caldav#725 ·

    Mantenedores costumam responder em até 1 dia

  • Test the library properly with Yahoo
    Aberta

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 48/100

    python-caldav/caldav#720 ·

    Mantenedores costumam responder em até 1 dia

  • Credentials are never sent to servers that omit WWW-Authenticate on 401 (e.g. Yahoo Calendar)
    Aberta

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 62/100

    python-caldav/caldav#713 · 5 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Configuration: allow password-yielding commands in config file.
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 30/100

    python-caldav/caldav#704 ·

    Mantenedores costumam responder em até 1 dia

  • Extended MKCOL (RFC 5689): detection, testing and 207 handling
    Aberta
    enhancement roadmap

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 45/100

    python-caldav/caldav#702 ·

    Mantenedores costumam responder em até 1 dia

  • Support calendar sharing (draft-pot-caldav-sharing)
    Aberta
    enhancement roadmap

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#701 ·

    Mantenedores costumam responder em até 1 dia

  • Support managed attachments (RFC 8607)
    Aberta
    enhancement roadmap

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#700 ·

    Mantenedores costumam responder em até 1 dia

  • Implement WebDAV ACL operations on calendars (RFC 3744)
    Aberta
    enhancement roadmap

    Dificuldade 5/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#699 ·

    Mantenedores costumam responder em até 1 dia

  • Parse server iCalendar through vcal.parse_ical() consistently
    Aberta
    refactoring

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 48/100

    python-caldav/caldav#698 ·

    Mantenedores costumam responder em até 1 dia

  • Rate-limit handling to count requests
    Aberta
    enhancement

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 35/100

    python-caldav/caldav#697 ·

    Mantenedores costumam responder em até 1 dia

  • Sync mode support for the httpx family
    Aberta
    enhancement

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 32/100

    python-caldav/caldav#696 ·

    Mantenedores costumam responder em até 1 dia

  • Retries on connection failures and on a closed idle keep-alive connection
    Aberta
    enhancement

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 38/100

    python-caldav/caldav#695 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • require_tls only enforced on RFC 6764 discovery, not on explicit URLs
    Aberta

    Dificuldade 2/5 1-3 horas Facilidade para iniciantes 62/100

    python-caldav/caldav#687 ·

    Mantenedores costumam responder em até 1 dia

  • AssertionError ("Deviation from expectations found") when using Infomaniak CalDAV with Home Assistant Container
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 38/100

    python-caldav/caldav#684 · 5 comentários ·

    Mantenedores costumam responder em até 1 dia

  • WebDAV Push support
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 30/100

    python-caldav/caldav#674 · 4 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Async refactoring: reduce code duplication
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 32/100

    python-caldav/caldav#665 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • "Protocol layer" cleanup
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#664 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • FeatureSet cleanup: simplify over-complex type-system remnants in compatibility_hints.py
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 45/100

    python-caldav/caldav#659 ·

    Mantenedores costumam responder em até 1 dia

  • Ruff ignore list is too long
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#634 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • GMX calendar creation not working very well
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    python-caldav/caldav#624 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • v4.0 - rip out all deprecated methods that yields deprecationwarning
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#619 ·

    Mantenedores costumam responder em até 1 dia

  • Auto-detection of server quirks
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 28/100

    python-caldav/caldav#600 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • Roadmap Updates
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 20/100

    python-caldav/caldav#599 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Intelligent deletion of single recurrences
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#598 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Create helper methods for identifying various "recurrence states" for a CalendarObjectResource
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    python-caldav/caldav#597 ·

    Mantenedores costumam responder em até 1 dia

  • Refactor setup/teardown methods in the functional test setup
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#593 ·

    Mantenedores costumam responder em até 1 dia

  • Feature configuration subsystem: extra_features and include
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#592 ·

    Mantenedores costumam responder em até 1 dia

  • Remove the old incompatibility flags completely
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#585 ·

    Mantenedores costumam responder em até 1 dia

  • `tests/conf.py` is a mess
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    python-caldav/caldav#577 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • Support negated searches
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#568 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • Improved collation support for non-ascii case-insensitive text-match
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#567 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • Follow PROPFIND redirects
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#552 · 3 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Searching also returns full-day events of adjacent days
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 48/100

    python-caldav/caldav#545 · 6 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Docs and example code: use the icalendar .new method
    Aberta
    doc

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 42/100

    python-caldav/caldav#541 · 3 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Find and kill instances of `event.component['uid']` et al
    Aberta

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#515 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Documentation howtos
    Aberta
    doc

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#513 ·

    Mantenedores costumam responder em até 1 dia

  • Support RFC 7953 Availability
    Aberta
    enhancement

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#425 ·

    Mantenedores costumam responder em até 1 dia

  • Improvements, test code and documentation needed for editing and selecting recurrence instances
    Aberta
    doc

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    python-caldav/caldav#398 · 4 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Collission avoidance
    Aberta
    enhancement

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 45/100

    python-caldav/caldav#152 ·

    Mantenedores costumam responder em até 1 dia

  • Support for alarms
    Aberta
    enhancement

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 35/100

    python-caldav/caldav#132 · 6 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Documentation for each server/cloud provider
    Aberta
    doc enhancement

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    python-caldav/caldav#120 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Increase test coverage
    Aberta
    testing regime

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    python-caldav/caldav#93 · 3 comentários ·

    Mantenedores costumam responder em até 1 dia

  • Caldav test servers
    Aberta
    help wanted roadmap testing regime

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 18/100

    python-caldav/caldav#45 · 20 comentários ·

    Mantenedores costumam responder em até 1 dia

  • get_calendars() returns [] for a Nextcloud public calendar share (regression from 2.x)
    Talvez já em andamento @IT-BAER assumiu hoje. Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 45/100

    python-caldav/caldav#743 ·

    Mantenedores costumam responder em até 1 dia

  • delete() sends no If-Match, so a concurrent change is deleted silently
    Talvez já em andamento @tobixen assumiu hoje. Aberta

    Dificuldade 3/5 Meio dia Facilidade para iniciantes 22/100

    python-caldav/caldav#740 ·

    Mantenedores costumam responder em até 1 dia

  • Todo.complete(rrule_mode="this_and_future") raises AttributeError; only the undeclared "thisandfuture" works
    Talvez já em andamento @muratatar06 assumiu há 1 dia. Aberta

    Dificuldade 2/5 1-3 horas Facilidade para iniciantes 66/100

    python-caldav/caldav#735 ·

    Mantenedores costumam responder em até 1 dia

  • iCloud: URL.join raises "can't be joined" when REPORT hrefs use caldav.icloud.com after client.url was rewritten to the pNN partition host
    Talvez já em andamento @tobixen assumiu há 1 dia. Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 52/100

    python-caldav/caldav#730 · 2 comentários ·

    Mantenedores costumam responder em até 1 dia

  • change_attendee_status() not completely async safe
    Talvez já em andamento @Ehsan-hash assumiu há 1 dia. Aberta

    Dificuldade 3/5 1-2 dias Facilidade para iniciantes 48/100

    python-caldav/caldav#678 · 1 comentário ·

    Mantenedores costumam responder em até 1 dia

  • v4.0 - requests, niquests, httpx or something else?
    Talvez já em andamento Um pull request vinculado a esta issue está aberto ou já foi mesclado. Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 20/100

    python-caldav/caldav#611 · 20 comentários ·

    Mantenedores costumam responder em até 1 dia

Receba novas issues na sua caixa de entrada

Um resumo curto de issues do GitHub para quem está começando.