Hacktoberfest 2026: những issue maintainer đã đánh dấu cho tháng Mười, đang mở và phù hợp người mới. Xem issue Hacktoberfest

Eclipse tinydtls

eclipse-tinydtls/tinydtls có thân thiện với người mới không?

Trong 30 ngày gần nhất, eclipse-tinydtls/tinydtls đã merge 5 trên 14 pull request của người đóng góp bên ngoài, và maintainer thường phản hồi trong vòng 2 ngày. Hiện có 1 issue phù hợp với người mới đang mở.

Star
122
Fork
67
Issue cho người mới đang mở
1
Issue đã lập chỉ mục
20
Merge trung bình
6 ngày 8 giờ
Pull request đã merge (30 ngày)
5
Ngôn ngữ chính
C
Giấy phép
Không có dữ liệu giấy phép
Lần push lên GitHub gần nhất
5/10/2026
Lập chỉ mục gần nhất
6/10/2026
Hướng dẫn đóng góp
Hướng dẫn đóng góp
Quy tắc ứng xử
Không có quy tắc ứng xử
Label cho người mới
good first issue

Cách đóng góp cho eclipse-tinydtls/tinydtls

  1. Hãy đọc hướng dẫn đóng góp trước: nó cho biết maintainer muốn thay đổi được đề xuất, kiểm thử và review ra sao.
  2. Chọn issue phù hợp với người mới đang mở bên dưới và bình luận rằng bạn muốn làm nó trước khi bắt đầu.

Các issue có thể đã có người làm được xếp cuối danh sách. Sắp xếp tất cả theo ngày

  • `dtls_get_cookie`: dereference before the length check (currently masked by `dtls_create_cookie`)
    Đang mở

    Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 68/100

    eclipse-tinydtls/tinydtls#279 · 2 bình luận · 1 reaction ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • `MASK_L` over-shifts for RFC 3610-legal `L ≥ 4`, collapsing the CCM counter (keystream reuse at `L = 4`)
    Đang mở

    Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 57/100

    eclipse-tinydtls/tinydtls#278 · 3 bình luận · 1 reaction ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • ECDSA Verification Without On-Curve Check
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 45/100

    eclipse-tinydtls/tinydtls#274 · 2 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • tinydtls Unbounded Handshake Reorder Queue DoS
    Đang mở
    bug

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 48/100

    eclipse-tinydtls/tinydtls#273 · 2 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • tinydtls `dtls_update_parameters` Assert-Only Length Guard
    Đang mở

    Độ khó 3/5 Nửa ngày Mức phù hợp với người mới 48/100

    eclipse-tinydtls/tinydtls#272 · 1 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • DTLS 1.2 (RFC 6347) Compliance Observations in tinydtls
    Có thể làm lại được @boaks đã nhận 178 ngày trước và không có pull request nào đang mở. Đang mở
    bug good first issue

    eclipse-tinydtls/tinydtls#268 · 2 bình luận · 1 reaction · 1 người được giao ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • New tag / version
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 25/100

    eclipse-tinydtls/tinydtls#261 · 6 bình luận · 1 reaction ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • (Non-conformance) Stateless Cookie Exchange
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 35/100

    eclipse-tinydtls/tinydtls#259 · 2 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • (Non-conformance) Wrapping of Record Sequence Number
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 30/100

    eclipse-tinydtls/tinydtls#258 · 1 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Experiencing an extended handshake duration on a SAMR21-xpro device.
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    eclipse-tinydtls/tinydtls#224 · 17 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • RFC7250 - RawPublicKey - No Suitable Certificate?
    Đang mở
    enhancement

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 25/100

    eclipse-tinydtls/tinydtls#186 · 1 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Issues for general cleanup?
    Đang mở
    question

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    eclipse-tinydtls/tinydtls#143 · 25 bình luận · 2 reaction ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • 32bit overflow does not work
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 30/100

    eclipse-tinydtls/tinydtls#125 · 9 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Fuzzing Hello_Extensions?
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 20/100

    eclipse-tinydtls/tinydtls#65 · 1 bình luận · 1 reaction ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Contact information to report a serious security vulnerablity
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 15/100

    eclipse-tinydtls/tinydtls#43 · 2 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Support for dtls connection id extension?
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 15/100

    eclipse-tinydtls/tinydtls#27 · 17 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Using retransmission timer
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 25/100

    eclipse-tinydtls/tinydtls#26 · 2 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • ECDHE_ECDSA ClientKeyExchange rejected as too short when DTLS_PSK_MAX_CLIENT_IDENTITY_LEN > 64
    Có thể đã có người làm Có pull request liên kết đang mở hoặc đã được merge. Đang mở
    bug good first issue please retest

    Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 76/100

    eclipse-tinydtls/tinydtls#298 · 2 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • MSVC build is broken (undeclared `DTLS_DEBUG_BUF_SIZE`)
    Có thể đã có người làm @mrdeep1 đã nhận 9 ngày trước. Đang mở

    Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 25/100

    eclipse-tinydtls/tinydtls#283 · 5 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

  • Server DoS vulnerability via malformed handshake sequence
    Có thể đã có người làm Có pull request liên kết đang mở hoặc đã được merge. Đang mở
    bug

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    eclipse-tinydtls/tinydtls#244 · 9 bình luận ·

    Maintainer thường phản hồi trong vòng 2 ngày

Nhận issue mới trong hộp thư của bạn

Bản tóm tắt ngắn những issue GitHub phù hợp với người mới.