Hacktoberfest 2026 : les issues que les mainteneurs ont marquées pour octobre, ouvertes et accessibles aux débutants. Parcourir les issues Hacktoberfest

Eclipse tinydtls

eclipse-tinydtls/tinydtls est-il accessible aux débutants ?

Ces 30 derniers jours, eclipse-tinydtls/tinydtls a fusionné 5 des 14 pull requests de contributeurs externes, et ses mainteneurs répondent en général sous 2 jours. 1 issue accessible aux débutants est ouverte en ce moment.

Étoiles
122
Forks
67
Issues débutants ouvertes
1
Issues indexées
20
Merge moyen
6 j 8 h
PR mergées (30 j)
5
Langage dominant
C
Licence
Aucune donnée de licence
Dernier push GitHub
5/10/2026
Dernière indexation
6/10/2026
Guide de contribution
Guide de contribution
Code de conduite
Aucun code de conduite
Labels débutants
good first issue

Comment contribuer à eclipse-tinydtls/tinydtls

  1. Lisez d'abord le guide de contribution : il explique comment les mainteneurs veulent que les changements soient proposés, testés et relus.
  2. Choisissez l'issue ouverte accessible aux débutants ci-dessous et indiquez en commentaire que vous voulez la prendre avant de commencer.

Les issues sur lesquelles quelqu’un travaille peut-être déjà sont listées en dernier. Tout trier par date

  • `dtls_get_cookie`: dereference before the length check (currently masked by `dtls_create_cookie`)
    Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 68/100

    eclipse-tinydtls/tinydtls#279 · 2 commentaires · 1 réaction ·

    Les mainteneurs répondent en général sous 2 jours

  • `MASK_L` over-shifts for RFC 3610-legal `L ≥ 4`, collapsing the CCM counter (keystream reuse at `L = 4`)
    Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 57/100

    eclipse-tinydtls/tinydtls#278 · 3 commentaires · 1 réaction ·

    Les mainteneurs répondent en général sous 2 jours

  • ECDSA Verification Without On-Curve Check
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 45/100

    eclipse-tinydtls/tinydtls#274 · 2 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • tinydtls Unbounded Handshake Reorder Queue DoS
    Ouverte
    bug

    Difficulté 4/5 3-5 jours Accessibilité débutants 48/100

    eclipse-tinydtls/tinydtls#273 · 2 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • tinydtls `dtls_update_parameters` Assert-Only Length Guard
    Ouverte

    Difficulté 3/5 Une demi-journée Accessibilité débutants 48/100

    eclipse-tinydtls/tinydtls#272 · 1 commentaire ·

    Les mainteneurs répondent en général sous 2 jours

  • DTLS 1.2 (RFC 6347) Compliance Observations in tinydtls
    Peut-être à nouveau libre @boaks l’a pris il y a 178 jours, et aucune pull request n’est ouverte. Ouverte
    bug good first issue

    eclipse-tinydtls/tinydtls#268 · 2 commentaires · 1 réaction · 1 personne assignée ·

    Les mainteneurs répondent en général sous 2 jours

  • New tag / version
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    eclipse-tinydtls/tinydtls#261 · 6 commentaires · 1 réaction ·

    Les mainteneurs répondent en général sous 2 jours

  • (Non-conformance) Stateless Cookie Exchange
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    eclipse-tinydtls/tinydtls#259 · 2 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • (Non-conformance) Wrapping of Record Sequence Number
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 30/100

    eclipse-tinydtls/tinydtls#258 · 1 commentaire ·

    Les mainteneurs répondent en général sous 2 jours

  • Experiencing an extended handshake duration on a SAMR21-xpro device.
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    eclipse-tinydtls/tinydtls#224 · 17 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • RFC7250 - RawPublicKey - No Suitable Certificate?
    Ouverte
    enhancement

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    eclipse-tinydtls/tinydtls#186 · 1 commentaire ·

    Les mainteneurs répondent en général sous 2 jours

  • Issues for general cleanup?
    Ouverte
    question

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    eclipse-tinydtls/tinydtls#143 · 25 commentaires · 2 réactions ·

    Les mainteneurs répondent en général sous 2 jours

  • 32bit overflow does not work
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 30/100

    eclipse-tinydtls/tinydtls#125 · 9 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • Fuzzing Hello_Extensions?
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 20/100

    eclipse-tinydtls/tinydtls#65 · 1 commentaire · 1 réaction ·

    Les mainteneurs répondent en général sous 2 jours

  • Contact information to report a serious security vulnerablity
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 15/100

    eclipse-tinydtls/tinydtls#43 · 2 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • Support for dtls connection id extension?
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 15/100

    eclipse-tinydtls/tinydtls#27 · 17 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • Using retransmission timer
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    eclipse-tinydtls/tinydtls#26 · 2 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • ECDHE_ECDSA ClientKeyExchange rejected as too short when DTLS_PSK_MAX_CLIENT_IDENTITY_LEN > 64
    Peut-être pris Une pull request liée à cette issue est ouverte ou déjà fusionnée. Ouverte
    bug good first issue please retest

    Difficulté 2/5 1-3 heures Accessibilité débutants 76/100

    eclipse-tinydtls/tinydtls#298 · 2 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • MSVC build is broken (undeclared `DTLS_DEBUG_BUF_SIZE`)
    Peut-être pris @mrdeep1 l’a pris il y a 9 jours. Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 25/100

    eclipse-tinydtls/tinydtls#283 · 5 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

  • Server DoS vulnerability via malformed handshake sequence
    Peut-être pris Une pull request liée à cette issue est ouverte ou déjà fusionnée. Ouverte
    bug

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    eclipse-tinydtls/tinydtls#244 · 9 commentaires ·

    Les mainteneurs répondent en général sous 2 jours

Recevez les nouvelles issues par e-mail

Un résumé court des issues GitHub adaptées aux débutants.