Hacktoberfest 2026: as issues que os mantenedores marcaram para outubro, abertas e boas para iniciantes. Ver issues do Hacktoberfest

eclipse-tinydtls/tinydtls

Eclipse tinydtls

eclipse-tinydtls/tinydtls é bom para iniciantes?

Nos últimos 30 dias, eclipse-tinydtls/tinydtls fez merge de 5 de 14 pull requests de contribuidores externos, e os mantenedores costumam responder em até 2 dias. Agora há 2 issues para iniciantes abertas.

Estrelas
122
Forks
67
Issues abertas para iniciantes
2
Issues indexadas
20
Merge médio
6d 8h
PRs com merge (30d)
5
Linguagem predominante
C
Licença
Sem dados de licença
Último push no GitHub
5/10/2026
Última indexação
6/10/2026
Guia de contribuição
Guia de contribuição
Código de conduta
Sem código de conduta
Labels para iniciantes
good first issue

Como contribuir com eclipse-tinydtls/tinydtls

  1. Leia primeiro o guia de contribuição: ele explica como os mantenedores querem que as mudanças sejam propostas, testadas e revisadas.
  2. Escolha uma das 2 issues abertas para iniciantes abaixo e comente que quer trabalhar nela antes de começar.
Carregando issues

Issues em que talvez alguém já esteja trabalhando aparecem no fim. Ordenar tudo por data

  • `dtls_get_cookie`: dereference before the length check (currently masked by `dtls_create_cookie`)
    Aberta

    Dificuldade 2/5 1-3 horas Facilidade para iniciantes 68/100

    eclipse-tinydtls/tinydtls#279 · 2 comentários · 1 reação ·

    Mantenedores costumam responder em até 2 dias

  • `MASK_L` over-shifts for RFC 3610-legal `L ≥ 4`, collapsing the CCM counter (keystream reuse at `L = 4`)
    Aberta

    Dificuldade 2/5 1-3 horas Facilidade para iniciantes 57/100

    eclipse-tinydtls/tinydtls#278 · 3 comentários · 1 reação ·

    Mantenedores costumam responder em até 2 dias

  • ECDSA Verification Without On-Curve Check
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 45/100

    eclipse-tinydtls/tinydtls#274 · 2 comentários ·

    Mantenedores costumam responder em até 2 dias

  • tinydtls Unbounded Handshake Reorder Queue DoS
    Aberta
    bug

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 48/100

    eclipse-tinydtls/tinydtls#273 · 2 comentários ·

    Mantenedores costumam responder em até 2 dias

  • tinydtls `dtls_update_parameters` Assert-Only Length Guard
    Aberta

    Dificuldade 3/5 Meio dia Facilidade para iniciantes 48/100

    eclipse-tinydtls/tinydtls#272 · 1 comentário ·

    Mantenedores costumam responder em até 2 dias

  • DTLS 1.2 (RFC 6347) Compliance Observations in tinydtls
    Talvez livre de novo @boaks assumiu há 179 dias e não há nenhum pull request aberto. Aberta
    bug good first issue

    eclipse-tinydtls/tinydtls#268 · 2 comentários · 1 reação · 1 responsável ·

    Mantenedores costumam responder em até 2 dias

  • New tag / version
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    eclipse-tinydtls/tinydtls#261 · 6 comentários · 1 reação ·

    Mantenedores costumam responder em até 2 dias

  • (Non-conformance) Stateless Cookie Exchange
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 35/100

    eclipse-tinydtls/tinydtls#259 · 2 comentários ·

    Mantenedores costumam responder em até 2 dias

  • (Non-conformance) Wrapping of Record Sequence Number
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 30/100

    eclipse-tinydtls/tinydtls#258 · 1 comentário ·

    Mantenedores costumam responder em até 2 dias

  • Experiencing an extended handshake duration on a SAMR21-xpro device.
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 20/100

    eclipse-tinydtls/tinydtls#224 · 17 comentários ·

    Mantenedores costumam responder em até 2 dias

  • RFC7250 - RawPublicKey - No Suitable Certificate?
    Aberta
    enhancement

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    eclipse-tinydtls/tinydtls#186 · 1 comentário ·

    Mantenedores costumam responder em até 2 dias

  • Issues for general cleanup?
    Aberta
    question

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 20/100

    eclipse-tinydtls/tinydtls#143 · 25 comentários · 2 reações ·

    Mantenedores costumam responder em até 2 dias

  • 32bit overflow does not work
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 30/100

    eclipse-tinydtls/tinydtls#125 · 9 comentários ·

    Mantenedores costumam responder em até 2 dias

  • Fuzzing Hello_Extensions?
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 20/100

    eclipse-tinydtls/tinydtls#65 · 1 comentário · 1 reação ·

    Mantenedores costumam responder em até 2 dias

  • Contact information to report a serious security vulnerablity
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 15/100

    eclipse-tinydtls/tinydtls#43 · 2 comentários ·

    Mantenedores costumam responder em até 2 dias

  • Support for dtls connection id extension?
    Aberta

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 15/100

    eclipse-tinydtls/tinydtls#27 · 17 comentários ·

    Mantenedores costumam responder em até 2 dias

  • Using retransmission timer
    Aberta

    Dificuldade 4/5 3-5 dias Facilidade para iniciantes 25/100

    eclipse-tinydtls/tinydtls#26 · 2 comentários ·

    Mantenedores costumam responder em até 2 dias

  • ECDHE_ECDSA ClientKeyExchange rejected as too short when DTLS_PSK_MAX_CLIENT_IDENTITY_LEN > 64
    Talvez já em andamento Um pull request vinculado a esta issue está aberto ou já foi mesclado. Aberta
    bug good first issue please retest

    Dificuldade 2/5 1-3 horas Facilidade para iniciantes 76/100

    eclipse-tinydtls/tinydtls#298 · 2 comentários ·

    Mantenedores costumam responder em até 2 dias

  • MSVC build is broken (undeclared `DTLS_DEBUG_BUF_SIZE`)
    Talvez já em andamento @mrdeep1 assumiu há 10 dias. Aberta

    Dificuldade 2/5 1-3 horas Facilidade para iniciantes 25/100

    eclipse-tinydtls/tinydtls#283 · 5 comentários ·

    Mantenedores costumam responder em até 2 dias

  • Server DoS vulnerability via malformed handshake sequence
    Talvez já em andamento Um pull request vinculado a esta issue está aberto ou já foi mesclado. Aberta
    bug

    Dificuldade 5/5 Mais de uma semana Facilidade para iniciantes 25/100

    eclipse-tinydtls/tinydtls#244 · 9 comentários ·

    Mantenedores costumam responder em até 2 dias

Receba novas issues na sua caixa de entrada

Um resumo curto de issues do GitHub para quem está começando.