Hacktoberfest 2026: le issue che i maintainer hanno segnato per ottobre, aperte e adatte ai principianti. Sfoglia le issue Hacktoberfest

eclipse-tinydtls/tinydtls

Eclipse tinydtls

eclipse-tinydtls/tinydtls è adatto ai principianti?

Negli ultimi 30 giorni eclipse-tinydtls/tinydtls ha accettato 5 delle 14 pull request di contributori esterni, e i suoi maintainer di solito rispondono entro 2 giorni. In questo momento sono aperte 2 issue adatte ai principianti.

Stelle
122
Fork
67
Issue aperte per principianti
2
Issue indicizzate
20
Merge medio
6g 8h
PR unite (30g)
5
Lingua principale
C
Licenza
Nessun dato sulla licenza
Ultimo push su GitHub
5/10/2026
Ultima indicizzazione
6/10/2026
Guida per i contributori
Guida per i contributori
Codice di condotta
Nessun codice di condotta
Label per principianti
good first issue

Come contribuire a eclipse-tinydtls/tinydtls

  1. Leggi prima la guida per contribuire: spiega come i maintainer vogliono che le modifiche siano proposte, testate e revisionate.
  2. Scegli una delle 2 issue aperte adatte ai principianti qui sotto e, prima di iniziare, scrivi in un commento che vuoi occupartene.
Caricamento delle issue

Le issue su cui forse qualcuno sta già lavorando sono in fondo alla lista. Ordina tutto per data

  • `dtls_get_cookie`: dereference before the length check (currently masked by `dtls_create_cookie`)
    Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 68/100

    eclipse-tinydtls/tinydtls#279 · 2 commenti · 1 reazione ·

    I maintainer di solito rispondono entro 2 giorni

  • `MASK_L` over-shifts for RFC 3610-legal `L ≥ 4`, collapsing the CCM counter (keystream reuse at `L = 4`)
    Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 57/100

    eclipse-tinydtls/tinydtls#278 · 3 commenti · 1 reazione ·

    I maintainer di solito rispondono entro 2 giorni

  • ECDSA Verification Without On-Curve Check
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 45/100

    eclipse-tinydtls/tinydtls#274 · 2 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • tinydtls Unbounded Handshake Reorder Queue DoS
    Aperta
    bug

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 48/100

    eclipse-tinydtls/tinydtls#273 · 2 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • tinydtls `dtls_update_parameters` Assert-Only Length Guard
    Aperta

    Difficoltà 3/5 Mezza giornata Idoneità per principianti 48/100

    eclipse-tinydtls/tinydtls#272 · 1 commento ·

    I maintainer di solito rispondono entro 2 giorni

  • DTLS 1.2 (RFC 6347) Compliance Observations in tinydtls
    Forse di nuovo libera @boaks l’ha presa 179 giorni fa e non c’è nessuna pull request aperta. Aperta
    bug good first issue

    eclipse-tinydtls/tinydtls#268 · 2 commenti · 1 reazione · 1 assegnatario ·

    I maintainer di solito rispondono entro 2 giorni

  • New tag / version
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    eclipse-tinydtls/tinydtls#261 · 6 commenti · 1 reazione ·

    I maintainer di solito rispondono entro 2 giorni

  • (Non-conformance) Stateless Cookie Exchange
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    eclipse-tinydtls/tinydtls#259 · 2 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • (Non-conformance) Wrapping of Record Sequence Number
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 30/100

    eclipse-tinydtls/tinydtls#258 · 1 commento ·

    I maintainer di solito rispondono entro 2 giorni

  • Experiencing an extended handshake duration on a SAMR21-xpro device.
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    eclipse-tinydtls/tinydtls#224 · 17 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • RFC7250 - RawPublicKey - No Suitable Certificate?
    Aperta
    enhancement

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    eclipse-tinydtls/tinydtls#186 · 1 commento ·

    I maintainer di solito rispondono entro 2 giorni

  • Issues for general cleanup?
    Aperta
    question

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    eclipse-tinydtls/tinydtls#143 · 25 commenti · 2 reazioni ·

    I maintainer di solito rispondono entro 2 giorni

  • 32bit overflow does not work
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 30/100

    eclipse-tinydtls/tinydtls#125 · 9 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • Fuzzing Hello_Extensions?
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 20/100

    eclipse-tinydtls/tinydtls#65 · 1 commento · 1 reazione ·

    I maintainer di solito rispondono entro 2 giorni

  • Contact information to report a serious security vulnerablity
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 15/100

    eclipse-tinydtls/tinydtls#43 · 2 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • Support for dtls connection id extension?
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 15/100

    eclipse-tinydtls/tinydtls#27 · 17 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • Using retransmission timer
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    eclipse-tinydtls/tinydtls#26 · 2 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • ECDHE_ECDSA ClientKeyExchange rejected as too short when DTLS_PSK_MAX_CLIENT_IDENTITY_LEN > 64
    Forse già presa Una pull request collegata a questa issue è aperta o già unita. Aperta
    bug good first issue please retest

    Difficoltà 2/5 1-3 ore Idoneità per principianti 76/100

    eclipse-tinydtls/tinydtls#298 · 2 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • MSVC build is broken (undeclared `DTLS_DEBUG_BUF_SIZE`)
    Forse già presa @mrdeep1 l’ha presa 10 giorni fa. Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 25/100

    eclipse-tinydtls/tinydtls#283 · 5 commenti ·

    I maintainer di solito rispondono entro 2 giorni

  • Server DoS vulnerability via malformed handshake sequence
    Forse già presa Una pull request collegata a questa issue è aperta o già unita. Aperta
    bug

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    eclipse-tinydtls/tinydtls#244 · 9 commenti ·

    I maintainer di solito rispondono entro 2 giorni

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.