Hacktoberfest 2026: los issues que los mantenedores marcaron para octubre, abiertos y aptos para principiantes. Explorar issues de Hacktoberfest

Eclipse tinydtls

¿Es eclipse-tinydtls/tinydtls apto para principiantes?

En los últimos 30 días, eclipse-tinydtls/tinydtls fusionó 5 de 14 pull requests de colaboradores externos, y sus mantenedores suelen responder en 2 días. Ahora mismo hay 2 issues aptos para principiantes abiertos.

Estrellas
122
Forks
67
Issues abiertos para principiantes
2
Issues indexados
20
Merge medio
6 d 8 h
PR fusionados (30 d)
5
Lenguaje dominante
C
Licencia
Sin datos de licencia
Último push a GitHub
5/10/2026
Última indexación
6/10/2026
Guía de contribución
Guía de contribución
Código de conducta
Sin código de conducta
Etiquetas para principiantes
good first issue

Cómo contribuir a eclipse-tinydtls/tinydtls

  1. Lee primero la guía de contribución: explica cómo quieren los mantenedores que se propongan, prueben y revisen los cambios.
  2. Elige uno de los 2 issues abiertos aptos para principiantes de abajo y comenta que quieres trabajar en él antes de empezar.

Las issues en las que quizá ya trabaja alguien aparecen al final. Ordenar todo por fecha

  • `dtls_get_cookie`: dereference before the length check (currently masked by `dtls_create_cookie`)
    Abierto

    Dificultad 2/5 1-3 horas Aptitud para principiantes 68/100

    eclipse-tinydtls/tinydtls#279 · 2 comentarios · 1 reacción ·

    Los mantenedores suelen responder en 2 días

  • `MASK_L` over-shifts for RFC 3610-legal `L ≥ 4`, collapsing the CCM counter (keystream reuse at `L = 4`)
    Abierto

    Dificultad 2/5 1-3 horas Aptitud para principiantes 57/100

    eclipse-tinydtls/tinydtls#278 · 3 comentarios · 1 reacción ·

    Los mantenedores suelen responder en 2 días

  • ECDSA Verification Without On-Curve Check
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 45/100

    eclipse-tinydtls/tinydtls#274 · 2 comentarios ·

    Los mantenedores suelen responder en 2 días

  • tinydtls Unbounded Handshake Reorder Queue DoS
    Abierto
    bug

    Dificultad 4/5 3-5 días Aptitud para principiantes 48/100

    eclipse-tinydtls/tinydtls#273 · 2 comentarios ·

    Los mantenedores suelen responder en 2 días

  • tinydtls `dtls_update_parameters` Assert-Only Length Guard
    Abierto

    Dificultad 3/5 Medio día Aptitud para principiantes 48/100

    eclipse-tinydtls/tinydtls#272 · 1 comentario ·

    Los mantenedores suelen responder en 2 días

  • DTLS 1.2 (RFC 6347) Compliance Observations in tinydtls
    Quizá libre de nuevo @boaks la tomó hace 180 días y no hay ningún pull request abierto. Abierto
    bug good first issue

    eclipse-tinydtls/tinydtls#268 · 2 comentarios · 1 reacción · 1 asignado ·

    Los mantenedores suelen responder en 2 días

  • New tag / version
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    eclipse-tinydtls/tinydtls#261 · 6 comentarios · 1 reacción ·

    Los mantenedores suelen responder en 2 días

  • (Non-conformance) Stateless Cookie Exchange
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 35/100

    eclipse-tinydtls/tinydtls#259 · 2 comentarios ·

    Los mantenedores suelen responder en 2 días

  • (Non-conformance) Wrapping of Record Sequence Number
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 30/100

    eclipse-tinydtls/tinydtls#258 · 1 comentario ·

    Los mantenedores suelen responder en 2 días

  • Experiencing an extended handshake duration on a SAMR21-xpro device.
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 20/100

    eclipse-tinydtls/tinydtls#224 · 17 comentarios ·

    Los mantenedores suelen responder en 2 días

  • RFC7250 - RawPublicKey - No Suitable Certificate?
    Abierto
    enhancement

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    eclipse-tinydtls/tinydtls#186 · 1 comentario ·

    Los mantenedores suelen responder en 2 días

  • Issues for general cleanup?
    Abierto
    question

    Dificultad 5/5 Más de una semana Aptitud para principiantes 20/100

    eclipse-tinydtls/tinydtls#143 · 25 comentarios · 2 reacciones ·

    Los mantenedores suelen responder en 2 días

  • 32bit overflow does not work
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 30/100

    eclipse-tinydtls/tinydtls#125 · 9 comentarios ·

    Los mantenedores suelen responder en 2 días

  • Fuzzing Hello_Extensions?
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 20/100

    eclipse-tinydtls/tinydtls#65 · 1 comentario · 1 reacción ·

    Los mantenedores suelen responder en 2 días

  • Contact information to report a serious security vulnerablity
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 15/100

    eclipse-tinydtls/tinydtls#43 · 2 comentarios ·

    Los mantenedores suelen responder en 2 días

  • Support for dtls connection id extension?
    Abierto

    Dificultad 5/5 Más de una semana Aptitud para principiantes 15/100

    eclipse-tinydtls/tinydtls#27 · 17 comentarios ·

    Los mantenedores suelen responder en 2 días

  • Using retransmission timer
    Abierto

    Dificultad 4/5 3-5 días Aptitud para principiantes 25/100

    eclipse-tinydtls/tinydtls#26 · 2 comentarios ·

    Los mantenedores suelen responder en 2 días

  • ECDHE_ECDSA ClientKeyExchange rejected as too short when DTLS_PSK_MAX_CLIENT_IDENTITY_LEN > 64
    Posiblemente ocupada Un pull request vinculado a esta issue está abierto o ya se fusionó. Abierto
    bug good first issue please retest

    Dificultad 2/5 1-3 horas Aptitud para principiantes 76/100

    eclipse-tinydtls/tinydtls#298 · 2 comentarios ·

    Los mantenedores suelen responder en 2 días

  • MSVC build is broken (undeclared `DTLS_DEBUG_BUF_SIZE`)
    Posiblemente ocupada @mrdeep1 la tomó hace 11 días. Abierto

    Dificultad 2/5 1-3 horas Aptitud para principiantes 25/100

    eclipse-tinydtls/tinydtls#283 · 5 comentarios ·

    Los mantenedores suelen responder en 2 días

  • Server DoS vulnerability via malformed handshake sequence
    Posiblemente ocupada Un pull request vinculado a esta issue está abierto o ya se fusionó. Abierto
    bug

    Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100

    eclipse-tinydtls/tinydtls#244 · 9 comentarios ·

    Los mantenedores suelen responder en 2 días

Recibe los nuevos issues en tu correo

Un resumen breve de issues de GitHub para principiantes.