Ruby client api for Internet Message Access Protocol

ruby/net-imap có thân thiện với người mới không?

Gần đây có quá ít pull request của người đóng góp bên ngoài gửi tới ruby/net-imap để nói chúng được merge thường xuyên đến đâu. Hiện chưa có issue nào phù hợp với người mới đang mở; danh sách bên dưới là các issue khác chúng tôi có của kho này.

Star
121
Fork
47
Issue cho người mới đang mở
0
Issue đã lập chỉ mục
44
Merge trung bình
19 giờ 25 phút
Pull request đã merge (30 ngày)
3
Ngôn ngữ chính
Ruby
Giấy phép
Không có dữ liệu giấy phép
Lần push lên GitHub gần nhất
27/10/2026
Lập chỉ mục gần nhất
19/9/2026
Hướng dẫn đóng góp
Không có hướng dẫn đóng góp
Quy tắc ứng xử
Không có quy tắc ứng xử
Label cho người mới
help wanted

Cách đóng góp cho ruby/net-imap

  1. Dự án không có hướng dẫn đóng góp, vì vậy hãy bắt đầu từ README và vài pull request vừa được merge để xem thay đổi được đề xuất thế nào.
  2. Theo dõi kho này để biết khi có issue mới phù hợp với người mới, hoặc xem các issue khác bên dưới.

Các issue có thể đã có người làm được xếp cuối danh sách. Sắp xếp tất cả theo ngày

  • ResponseTooLargeError#literal_size is false (not nil) when a line exceeds max_response_size
    Đang mở

    Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 77/100

    ruby/net-imap#789 ·

  • 🐛 `QUOTA` support is broken for types other than `STORAGE`
    Đang mở
    bug

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 30/100

    ruby/net-imap#622 ·

  • Cannot use FakeServer
    Đang mở

    Độ khó 3/5 1-2 ngày Mức phù hợp với người mới 25/100

    ruby/net-imap#545 · 2 bình luận · 1 reaction ·

  • RFC7888 (2016): `LITERAL+` (obsoletes: RFC2088 1997)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 15/100

    ruby/net-imap#537 ·

  • [RFC3502] Support `MULTIAPPEND` extension (also RFC4466)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#536 ·

  • STARTTLS fails with custom certificate (mTLS)
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 35/100

    ruby/net-imap#526 · 7 bình luận ·

  • 🔒 Support `SCRAM-*-PLUS` with channel binding
    Đang mở
    SASL :lock:

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 38/100

    ruby/net-imap#487 · 3 bình luận · 1 reaction ·

  • Improve `SequenceSet` memory use and performance
    Đang mở
    performance sequence-set

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#484 ·

  • 🔒 Cancel SASL authentication after client-side exceptions
    Đang mở
    IMAP4rev1 IMAP4rev2 SASL :lock:

    Độ khó 3/5 1-2 ngày Mức phù hợp với người mới 50/100

    ruby/net-imap#310 ·

  • Flaky test with macOS platform
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 35/100

    ruby/net-imap#287 · 5 bình luận ·

  • Missing timeout for the CAPABILITY command
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 35/100

    ruby/net-imap#278 · 8 bình luận ·

  • versioning and incompatibilities
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#273 · 7 bình luận ·

  • "ResponseParseError: unexpected token `NUMBER` (expected `ATOM`)" on old exchange mail servers
    Đang mở

    Độ khó 3/5 1-2 ngày Mức phù hợp với người mới 45/100

    ruby/net-imap#250 · 4 bình luận ·

  • Warning: "historical binary regexp match /.../n against UTF-8 string"
    Đang mở

    Độ khó 3/5 1-2 ngày Mức phù hợp với người mới 38/100

    ruby/net-imap#219 ·

  • ResponseParseError in `envelope`: unknown token - #{???}
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 25/100

    ruby/net-imap#191 · 1 bình luận ·

  • Honor `STARTTLS` capability
    Đang mở
    IMAP4rev1

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 30/100

    ruby/net-imap#134 ·

  • Add arbitrary kwargs to `#fetch`/`#uid_fetch`, using RFC4466 tagged-ext syntax
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#133 ·

  • Add arbitrary kwargs to `#rename`, using `rename-params` syntax (RFC4466 tagged-ext)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 15/100

    ruby/net-imap#130 ·

  • Add UnparsedData (with `#to_str`)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#129 · 1 bình luận ·

  • Add ExtensionDataList (with `#to_ary`)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#128 · 1 bình luận ·

  • Add TaggedExtensionData (with `#to_hash`)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#127 · 1 bình luận ·

  • Add arbitrary kwargs to `#create`, using `create-params` syntax (RFC4466 tagged-ext)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 15/100

    ruby/net-imap#126 ·

  • Add `:use` kwarg to `#create` (RFC6154, SPECIAL-USE)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#125 ·

  • Add arbitrary kwargs to `#select`/`#examine`, using `select-params` syntax (RFC4466 tagged-ext)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#124 ·

  • Use modern TLS-related recommendations as per RFC7525, RFC7817, and RFC8314
    Đang mở
    IMAP4rev2

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#118 · 1 bình luận ·

  • RFC6154 (2011): `SPECIAL-USE` (mailbox attributes are in IMAP4rev2)
    Đang mở
    IMAP4rev2

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 35/100

    ruby/net-imap#108 ·

  • RFC7162 (2014): QRESYNC (recommended by IMAP4rev2)
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#107 ·

  • `date` dependency requires native compilation
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#96 · 6 bình luận ·

  • SASL: Add support for lazy-loaded properties and event callbacks
    Đang mở
    SASL :lock:

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#82 ·

  • Update parser grammar to match RFC3501 and RFC4466
    Đang mở
    IMAP4rev1 IMAP4rev2

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 35/100

    ruby/net-imap#50 ·

  • Honoring server-reported and client-enabled capabilities
    Đang mở
    IMAP4rev1 IMAP4rev2

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#49 · 3 bình luận ·

  • RFC4978 (2007): `COMPRESS=DEFLATE`
    Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#46 · 1 bình luận ·

  • RFC5819 (2010): `LIST-STATUS` (included in `IMAP4rev2`)
    Đang mở
    IMAP4rev2

    Độ khó 3/5 1-2 ngày Mức phù hợp với người mới 25/100

    ruby/net-imap#45 ·

  • RFC5258 (2008): `LIST-EXTENDED` (mostly included in `IMAP4rev2`)
    Đang mở
    IMAP4rev2

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 30/100

    ruby/net-imap#43 ·

  • RFC5182 (2008): `SEARCHRES` (included in `IMAP4rev2`)
    Đang mở
    IMAP4rev2

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 25/100

    ruby/net-imap#42 ·

  • RFC7888 (2016): `LITERAL-` (included in `IMAP4rev2`)
    Đang mở
    IMAP4rev2

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#37 ·

  • RFC4466 (2006): Collected Extensions to IMAP4 ABNF
    Đang mở
    IMAP4rev2

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#35 ·

  • `UTF-7` should be automatically encoded/decoded
    Đang mở
    IMAP4rev1

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 30/100

    ruby/net-imap#30 · 2 reaction ·

  • can't install "digest" dependency as an unpriviledged user
    Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 38/100

    ruby/net-imap#29 · 4 bình luận ·

  • Should we create a shared net-sasl gem?
    Có thể làm lại được @shugo đã nhận 2022 ngày trước và không có pull request nào đang mở. Đang mở
    SASL :lock:

    ruby/net-imap#23 · 6 bình luận · 1 reaction · 2 người được giao ·

  • Support for IMAP4rev2 and modern extensions
    Đang mở
    IMAP4rev1 IMAP4rev2

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 20/100

    ruby/net-imap#12 · 7 bình luận · 1 reaction ·

  • Add JRuby and TruffleRuby to CI
    Có thể đã có người làm @nevans đã nhận 403 ngày trước. Đang mở
    help wanted

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100

    ruby/net-imap#454 · 18 bình luận ·

  • Add `:vanished` kwarg to `#fetch`/`#uid_fetch` (RFC7162, QRESYNC)
    Có thể đã có người làm @nevans đã nhận 433 ngày trước. Đang mở

    Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 15/100

    ruby/net-imap#131 ·

  • Add `:qresync` kwarg to `#select`, `#examine` (RFC7162)
    Có thể đã có người làm @nevans đã nhận 431 ngày trước. Đang mở

    Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 15/100

    ruby/net-imap#123 ·

Nhận issue mới trong hộp thư của bạn

Bản tóm tắt ngắn những issue GitHub phù hợp với người mới.