Ruby client api for Internet Message Access Protocol

ruby/net-imap è adatto ai principianti?

Abbiamo visto troppo poche pull request recenti di contributori esterni su ruby/net-imap per dire quanto spesso vengono accettate. Al momento non è aperta nessuna issue adatta ai principianti; l'elenco qui sotto mostra le altre issue che abbiamo per questo repository.

Stelle
121
Fork
47
Issue aperte per principianti
0
Issue indicizzate
44
Merge medio
19h 25m
PR unite (30g)
3
Lingua principale
Ruby
Licenza
Nessun dato sulla licenza
Ultimo push su GitHub
27/10/2026
Ultima indicizzazione
19/9/2026
Guida per i contributori
Nessuna guida per i contributori
Codice di condotta
Nessun codice di condotta
Label per principianti
help wanted

Come contribuire a ruby/net-imap

  1. Non c'è una guida per contribuire: parti dal README e da alcune pull request accettate di recente per capire come si propongono le modifiche.
  2. Segui il repository per sapere quando si apre una nuova issue adatta ai principianti, oppure guarda le altre issue qui sotto.
Caricamento delle issue

Le issue su cui forse qualcuno sta già lavorando sono in fondo alla lista. Ordina tutto per data

  • ResponseTooLargeError#literal_size is false (not nil) when a line exceeds max_response_size
    Aperta

    Difficoltà 2/5 1-3 ore Idoneità per principianti 77/100

    ruby/net-imap#789 ·

  • 🐛 `QUOTA` support is broken for types other than `STORAGE`
    Aperta
    bug

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 30/100

    ruby/net-imap#622 ·

  • Cannot use FakeServer
    Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 25/100

    ruby/net-imap#545 · 2 commenti · 1 reazione ·

  • RFC7888 (2016): `LITERAL+` (obsoletes: RFC2088 1997)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 15/100

    ruby/net-imap#537 ·

  • [RFC3502] Support `MULTIAPPEND` extension (also RFC4466)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#536 ·

  • STARTTLS fails with custom certificate (mTLS)
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    ruby/net-imap#526 · 7 commenti ·

  • 🔒 Support `SCRAM-*-PLUS` with channel binding
    Aperta
    SASL :lock:

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 38/100

    ruby/net-imap#487 · 3 commenti · 1 reazione ·

  • Improve `SequenceSet` memory use and performance
    Aperta
    performance sequence-set

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#484 ·

  • 🔒 Cancel SASL authentication after client-side exceptions
    Aperta
    IMAP4rev1 IMAP4rev2 SASL :lock:

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 50/100

    ruby/net-imap#310 ·

  • Flaky test with macOS platform
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    ruby/net-imap#287 · 5 commenti ·

  • Missing timeout for the CAPABILITY command
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    ruby/net-imap#278 · 8 commenti ·

  • versioning and incompatibilities
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#273 · 7 commenti ·

  • "ResponseParseError: unexpected token `NUMBER` (expected `ATOM`)" on old exchange mail servers
    Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 45/100

    ruby/net-imap#250 · 4 commenti ·

  • Warning: "historical binary regexp match /.../n against UTF-8 string"
    Aperta

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 38/100

    ruby/net-imap#219 ·

  • ResponseParseError in `envelope`: unknown token - #{???}
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    ruby/net-imap#191 · 1 commento ·

  • Honor `STARTTLS` capability
    Aperta
    IMAP4rev1

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 30/100

    ruby/net-imap#134 ·

  • Add arbitrary kwargs to `#fetch`/`#uid_fetch`, using RFC4466 tagged-ext syntax
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#133 ·

  • Add arbitrary kwargs to `#rename`, using `rename-params` syntax (RFC4466 tagged-ext)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 15/100

    ruby/net-imap#130 ·

  • Add UnparsedData (with `#to_str`)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#129 · 1 commento ·

  • Add ExtensionDataList (with `#to_ary`)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#128 · 1 commento ·

  • Add TaggedExtensionData (with `#to_hash`)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#127 · 1 commento ·

  • Add arbitrary kwargs to `#create`, using `create-params` syntax (RFC4466 tagged-ext)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 15/100

    ruby/net-imap#126 ·

  • Add `:use` kwarg to `#create` (RFC6154, SPECIAL-USE)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#125 ·

  • Add arbitrary kwargs to `#select`/`#examine`, using `select-params` syntax (RFC4466 tagged-ext)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#124 ·

  • Use modern TLS-related recommendations as per RFC7525, RFC7817, and RFC8314
    Aperta
    IMAP4rev2

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#118 · 1 commento ·

  • RFC6154 (2011): `SPECIAL-USE` (mailbox attributes are in IMAP4rev2)
    Aperta
    IMAP4rev2

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 35/100

    ruby/net-imap#108 ·

  • RFC7162 (2014): QRESYNC (recommended by IMAP4rev2)
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#107 ·

  • `date` dependency requires native compilation
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#96 · 6 commenti ·

  • SASL: Add support for lazy-loaded properties and event callbacks
    Aperta
    SASL :lock:

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#82 ·

  • Update parser grammar to match RFC3501 and RFC4466
    Aperta
    IMAP4rev1 IMAP4rev2

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 35/100

    ruby/net-imap#50 ·

  • Honoring server-reported and client-enabled capabilities
    Aperta
    IMAP4rev1 IMAP4rev2

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#49 · 3 commenti ·

  • RFC4978 (2007): `COMPRESS=DEFLATE`
    Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#46 · 1 commento ·

  • RFC5819 (2010): `LIST-STATUS` (included in `IMAP4rev2`)
    Aperta
    IMAP4rev2

    Difficoltà 3/5 1-2 giorni Idoneità per principianti 25/100

    ruby/net-imap#45 ·

  • RFC5258 (2008): `LIST-EXTENDED` (mostly included in `IMAP4rev2`)
    Aperta
    IMAP4rev2

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 30/100

    ruby/net-imap#43 ·

  • RFC5182 (2008): `SEARCHRES` (included in `IMAP4rev2`)
    Aperta
    IMAP4rev2

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 25/100

    ruby/net-imap#42 ·

  • RFC7888 (2016): `LITERAL-` (included in `IMAP4rev2`)
    Aperta
    IMAP4rev2

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#37 ·

  • RFC4466 (2006): Collected Extensions to IMAP4 ABNF
    Aperta
    IMAP4rev2

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#35 ·

  • `UTF-7` should be automatically encoded/decoded
    Aperta
    IMAP4rev1

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 30/100

    ruby/net-imap#30 · 2 reazioni ·

  • can't install "digest" dependency as an unpriviledged user
    Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 38/100

    ruby/net-imap#29 · 4 commenti ·

  • Should we create a shared net-sasl gem?
    Forse di nuovo libera @shugo l’ha presa 2022 giorni fa e non c’è nessuna pull request aperta. Aperta
    SASL :lock:

    ruby/net-imap#23 · 6 commenti · 1 reazione · 2 assegnatari ·

  • Support for IMAP4rev2 and modern extensions
    Aperta
    IMAP4rev1 IMAP4rev2

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 20/100

    ruby/net-imap#12 · 7 commenti · 1 reazione ·

  • Add JRuby and TruffleRuby to CI
    Forse già presa @nevans l’ha presa 403 giorni fa. Aperta
    help wanted

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 25/100

    ruby/net-imap#454 · 18 commenti ·

  • Add `:vanished` kwarg to `#fetch`/`#uid_fetch` (RFC7162, QRESYNC)
    Forse già presa @nevans l’ha presa 433 giorni fa. Aperta

    Difficoltà 4/5 3-5 giorni Idoneità per principianti 15/100

    ruby/net-imap#131 ·

  • Add `:qresync` kwarg to `#select`, `#examine` (RFC7162)
    Forse già presa @nevans l’ha presa 431 giorni fa. Aperta

    Difficoltà 5/5 Più di una settimana Idoneità per principianti 15/100

    ruby/net-imap#123 ·

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.