Ruby client api for Internet Message Access Protocol

ruby/net-imap は初心者に優しい?

ruby/net-imap への外部コントリビューターの PR が最近は少なく、どのくらいマージされるかはまだ言えません。 初心者向けのオープンな issue は今はありません。下の一覧に、このリポジトリのほかの issue があります。

スター
121
フォーク
47
オープンの初心者向け issue
0
索引済み issue
44
平均マージ
19時間 25分
マージ済み PR(30日)
3
主要言語
Ruby
ライセンス
ライセンスのデータがありません
最終 GitHub push
2026年10月27日
最新の索引
2026年9月19日
コントリビューションガイド
コントリビューションガイドがありません
行動規範
行動規範がありません
初心者向けラベル
help wanted

ruby/net-imap にコントリビュートするには

  1. コントリビューションガイドはないので、README と最近マージされた PR をいくつか読んで、変更の出し方をつかみましょう。
  2. リポジトリをフォローすれば、新しい初心者向け issue が出たときにわかります。下のほかの issue も見てみましょう。
issue を読み込んでいます

誰かが対応中かもしれないイシューは最後に並べています。 すべて日付順に表示

  • ResponseTooLargeError#literal_size is false (not nil) when a line exceeds max_response_size
    オープン

    難易度 2/5 1〜3時間 初心者へのやさしさ 77/100

    ruby/net-imap#789 ·

  • 🐛 `QUOTA` support is broken for types other than `STORAGE`
    オープン
    bug

    難易度 5/5 1週間以上 初心者へのやさしさ 30/100

    ruby/net-imap#622 ·

  • Cannot use FakeServer
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 25/100

    ruby/net-imap#545 · コメント 2 件 · リアクション 1 件 ·

  • RFC7888 (2016): `LITERAL+` (obsoletes: RFC2088 1997)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 15/100

    ruby/net-imap#537 ·

  • [RFC3502] Support `MULTIAPPEND` extension (also RFC4466)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#536 ·

  • STARTTLS fails with custom certificate (mTLS)
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    ruby/net-imap#526 · コメント 7 件 ·

  • 🔒 Support `SCRAM-*-PLUS` with channel binding
    オープン
    SASL :lock:

    難易度 4/5 3〜5日 初心者へのやさしさ 38/100

    ruby/net-imap#487 · コメント 3 件 · リアクション 1 件 ·

  • Improve `SequenceSet` memory use and performance
    オープン
    performance sequence-set

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#484 ·

  • 🔒 Cancel SASL authentication after client-side exceptions
    オープン
    IMAP4rev1 IMAP4rev2 SASL :lock:

    難易度 3/5 1〜2日 初心者へのやさしさ 50/100

    ruby/net-imap#310 ·

  • Flaky test with macOS platform
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    ruby/net-imap#287 · コメント 5 件 ·

  • Missing timeout for the CAPABILITY command
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    ruby/net-imap#278 · コメント 8 件 ·

  • versioning and incompatibilities
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#273 · コメント 7 件 ·

  • "ResponseParseError: unexpected token `NUMBER` (expected `ATOM`)" on old exchange mail servers
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 45/100

    ruby/net-imap#250 · コメント 4 件 ·

  • Warning: "historical binary regexp match /.../n against UTF-8 string"
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 38/100

    ruby/net-imap#219 ·

  • ResponseParseError in `envelope`: unknown token - #{???}
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    ruby/net-imap#191 · コメント 1 件 ·

  • Honor `STARTTLS` capability
    オープン
    IMAP4rev1

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    ruby/net-imap#134 ·

  • Add arbitrary kwargs to `#fetch`/`#uid_fetch`, using RFC4466 tagged-ext syntax
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#133 ·

  • Add arbitrary kwargs to `#rename`, using `rename-params` syntax (RFC4466 tagged-ext)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 15/100

    ruby/net-imap#130 ·

  • Add UnparsedData (with `#to_str`)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#129 · コメント 1 件 ·

  • Add ExtensionDataList (with `#to_ary`)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#128 · コメント 1 件 ·

  • Add TaggedExtensionData (with `#to_hash`)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#127 · コメント 1 件 ·

  • Add arbitrary kwargs to `#create`, using `create-params` syntax (RFC4466 tagged-ext)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 15/100

    ruby/net-imap#126 ·

  • Add `:use` kwarg to `#create` (RFC6154, SPECIAL-USE)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#125 ·

  • Add arbitrary kwargs to `#select`/`#examine`, using `select-params` syntax (RFC4466 tagged-ext)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#124 ·

  • Use modern TLS-related recommendations as per RFC7525, RFC7817, and RFC8314
    オープン
    IMAP4rev2

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#118 · コメント 1 件 ·

  • RFC6154 (2011): `SPECIAL-USE` (mailbox attributes are in IMAP4rev2)
    オープン
    IMAP4rev2

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    ruby/net-imap#108 ·

  • RFC7162 (2014): QRESYNC (recommended by IMAP4rev2)
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#107 ·

  • `date` dependency requires native compilation
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#96 · コメント 6 件 ·

  • SASL: Add support for lazy-loaded properties and event callbacks
    オープン
    SASL :lock:

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#82 ·

  • Update parser grammar to match RFC3501 and RFC4466
    オープン
    IMAP4rev1 IMAP4rev2

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    ruby/net-imap#50 ·

  • Honoring server-reported and client-enabled capabilities
    オープン
    IMAP4rev1 IMAP4rev2

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#49 · コメント 3 件 ·

  • RFC4978 (2007): `COMPRESS=DEFLATE`
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#46 · コメント 1 件 ·

  • RFC5819 (2010): `LIST-STATUS` (included in `IMAP4rev2`)
    オープン
    IMAP4rev2

    難易度 3/5 1〜2日 初心者へのやさしさ 25/100

    ruby/net-imap#45 ·

  • RFC5258 (2008): `LIST-EXTENDED` (mostly included in `IMAP4rev2`)
    オープン
    IMAP4rev2

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    ruby/net-imap#43 ·

  • RFC5182 (2008): `SEARCHRES` (included in `IMAP4rev2`)
    オープン
    IMAP4rev2

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    ruby/net-imap#42 ·

  • RFC7888 (2016): `LITERAL-` (included in `IMAP4rev2`)
    オープン
    IMAP4rev2

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#37 ·

  • RFC4466 (2006): Collected Extensions to IMAP4 ABNF
    オープン
    IMAP4rev2

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#35 ·

  • `UTF-7` should be automatically encoded/decoded
    オープン
    IMAP4rev1

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    ruby/net-imap#30 · リアクション 2 件 ·

  • can't install "digest" dependency as an unpriviledged user
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 38/100

    ruby/net-imap#29 · コメント 4 件 ·

  • Should we create a shared net-sasl gem?
    再び着手できるかも @shugo が 2022 日前に担当しましたが、オープン中のプルリクエストはありません。 オープン
    SASL :lock:

    ruby/net-imap#23 · コメント 6 件 · リアクション 1 件 · 担当者 2 名 ·

  • Support for IMAP4rev2 and modern extensions
    オープン
    IMAP4rev1 IMAP4rev2

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    ruby/net-imap#12 · コメント 7 件 · リアクション 1 件 ·

  • Add JRuby and TruffleRuby to CI
    対応中かも @nevans が 403 日前に担当しました。 オープン
    help wanted

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    ruby/net-imap#454 · コメント 18 件 ·

  • Add `:vanished` kwarg to `#fetch`/`#uid_fetch` (RFC7162, QRESYNC)
    対応中かも @nevans が 433 日前に担当しました。 オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 15/100

    ruby/net-imap#131 ·

  • Add `:qresync` kwarg to `#select`, `#examine` (RFC7162)
    対応中かも @nevans が 431 日前に担当しました。 オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 15/100

    ruby/net-imap#123 ·

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。