Ruby client api for Internet Message Access Protocol

ruby/net-imap est-il accessible aux débutants ?

Nous avons vu trop peu de pull requests récentes de contributeurs externes sur ruby/net-imap pour dire à quelle fréquence elles sont fusionnées. Aucune issue accessible aux débutants n'est ouverte pour l'instant ; la liste ci-dessous montre les autres issues que nous avons pour ce dépôt.

Étoiles
121
Forks
47
Issues débutants ouvertes
0
Issues indexées
44
Merge moyen
19 h 25 min
PR mergées (30 j)
3
Langage dominant
Ruby
Licence
Aucune donnée de licence
Dernier push GitHub
27/10/2026
Dernière indexation
19/9/2026
Guide de contribution
Aucun guide de contribution
Code de conduite
Aucun code de conduite
Labels débutants
help wanted

Comment contribuer à ruby/net-imap

  1. Il n'y a pas de guide de contribution : partez du README et de quelques pull requests fusionnées récemment pour voir comment les changements sont proposés.
  2. Suivez le dépôt pour savoir quand une nouvelle issue accessible aux débutants s'ouvre, ou parcourez les autres issues ci-dessous.

Les issues sur lesquelles quelqu’un travaille peut-être déjà sont listées en dernier. Tout trier par date

  • ResponseTooLargeError#literal_size is false (not nil) when a line exceeds max_response_size
    Ouverte

    Difficulté 2/5 1-3 heures Accessibilité débutants 77/100

    ruby/net-imap#789 ·

  • 🐛 `QUOTA` support is broken for types other than `STORAGE`
    Ouverte
    bug

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 30/100

    ruby/net-imap#622 ·

  • Cannot use FakeServer
    Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 25/100

    ruby/net-imap#545 · 2 commentaires · 1 réaction ·

  • RFC7888 (2016): `LITERAL+` (obsoletes: RFC2088 1997)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 15/100

    ruby/net-imap#537 ·

  • [RFC3502] Support `MULTIAPPEND` extension (also RFC4466)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#536 ·

  • STARTTLS fails with custom certificate (mTLS)
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    ruby/net-imap#526 · 7 commentaires ·

  • 🔒 Support `SCRAM-*-PLUS` with channel binding
    Ouverte
    SASL :lock:

    Difficulté 4/5 3-5 jours Accessibilité débutants 38/100

    ruby/net-imap#487 · 3 commentaires · 1 réaction ·

  • Improve `SequenceSet` memory use and performance
    Ouverte
    performance sequence-set

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#484 ·

  • 🔒 Cancel SASL authentication after client-side exceptions
    Ouverte
    IMAP4rev1 IMAP4rev2 SASL :lock:

    Difficulté 3/5 1-2 jours Accessibilité débutants 50/100

    ruby/net-imap#310 ·

  • Flaky test with macOS platform
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    ruby/net-imap#287 · 5 commentaires ·

  • Missing timeout for the CAPABILITY command
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    ruby/net-imap#278 · 8 commentaires ·

  • versioning and incompatibilities
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#273 · 7 commentaires ·

  • "ResponseParseError: unexpected token `NUMBER` (expected `ATOM`)" on old exchange mail servers
    Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 45/100

    ruby/net-imap#250 · 4 commentaires ·

  • Warning: "historical binary regexp match /.../n against UTF-8 string"
    Ouverte

    Difficulté 3/5 1-2 jours Accessibilité débutants 38/100

    ruby/net-imap#219 ·

  • ResponseParseError in `envelope`: unknown token - #{???}
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    ruby/net-imap#191 · 1 commentaire ·

  • Honor `STARTTLS` capability
    Ouverte
    IMAP4rev1

    Difficulté 4/5 3-5 jours Accessibilité débutants 30/100

    ruby/net-imap#134 ·

  • Add arbitrary kwargs to `#fetch`/`#uid_fetch`, using RFC4466 tagged-ext syntax
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#133 ·

  • Add arbitrary kwargs to `#rename`, using `rename-params` syntax (RFC4466 tagged-ext)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 15/100

    ruby/net-imap#130 ·

  • Add UnparsedData (with `#to_str`)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#129 · 1 commentaire ·

  • Add ExtensionDataList (with `#to_ary`)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#128 · 1 commentaire ·

  • Add TaggedExtensionData (with `#to_hash`)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#127 · 1 commentaire ·

  • Add arbitrary kwargs to `#create`, using `create-params` syntax (RFC4466 tagged-ext)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 15/100

    ruby/net-imap#126 ·

  • Add `:use` kwarg to `#create` (RFC6154, SPECIAL-USE)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#125 ·

  • Add arbitrary kwargs to `#select`/`#examine`, using `select-params` syntax (RFC4466 tagged-ext)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#124 ·

  • Use modern TLS-related recommendations as per RFC7525, RFC7817, and RFC8314
    Ouverte
    IMAP4rev2

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#118 · 1 commentaire ·

  • RFC6154 (2011): `SPECIAL-USE` (mailbox attributes are in IMAP4rev2)
    Ouverte
    IMAP4rev2

    Difficulté 4/5 3-5 jours Accessibilité débutants 35/100

    ruby/net-imap#108 ·

  • RFC7162 (2014): QRESYNC (recommended by IMAP4rev2)
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#107 ·

  • `date` dependency requires native compilation
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#96 · 6 commentaires ·

  • SASL: Add support for lazy-loaded properties and event callbacks
    Ouverte
    SASL :lock:

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#82 ·

  • Update parser grammar to match RFC3501 and RFC4466
    Ouverte
    IMAP4rev1 IMAP4rev2

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 35/100

    ruby/net-imap#50 ·

  • Honoring server-reported and client-enabled capabilities
    Ouverte
    IMAP4rev1 IMAP4rev2

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#49 · 3 commentaires ·

  • RFC4978 (2007): `COMPRESS=DEFLATE`
    Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#46 · 1 commentaire ·

  • RFC5819 (2010): `LIST-STATUS` (included in `IMAP4rev2`)
    Ouverte
    IMAP4rev2

    Difficulté 3/5 1-2 jours Accessibilité débutants 25/100

    ruby/net-imap#45 ·

  • RFC5258 (2008): `LIST-EXTENDED` (mostly included in `IMAP4rev2`)
    Ouverte
    IMAP4rev2

    Difficulté 4/5 3-5 jours Accessibilité débutants 30/100

    ruby/net-imap#43 ·

  • RFC5182 (2008): `SEARCHRES` (included in `IMAP4rev2`)
    Ouverte
    IMAP4rev2

    Difficulté 4/5 3-5 jours Accessibilité débutants 25/100

    ruby/net-imap#42 ·

  • RFC7888 (2016): `LITERAL-` (included in `IMAP4rev2`)
    Ouverte
    IMAP4rev2

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#37 ·

  • RFC4466 (2006): Collected Extensions to IMAP4 ABNF
    Ouverte
    IMAP4rev2

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#35 ·

  • `UTF-7` should be automatically encoded/decoded
    Ouverte
    IMAP4rev1

    Difficulté 4/5 3-5 jours Accessibilité débutants 30/100

    ruby/net-imap#30 · 2 réactions ·

  • can't install "digest" dependency as an unpriviledged user
    Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 38/100

    ruby/net-imap#29 · 4 commentaires ·

  • Should we create a shared net-sasl gem?
    Peut-être à nouveau libre @shugo l’a pris il y a 2022 jours, et aucune pull request n’est ouverte. Ouverte
    SASL :lock:

    ruby/net-imap#23 · 6 commentaires · 1 réaction · 2 personnes assignées ·

  • Support for IMAP4rev2 and modern extensions
    Ouverte
    IMAP4rev1 IMAP4rev2

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 20/100

    ruby/net-imap#12 · 7 commentaires · 1 réaction ·

  • Add JRuby and TruffleRuby to CI
    Peut-être pris @nevans l’a pris il y a 403 jours. Ouverte
    help wanted

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 25/100

    ruby/net-imap#454 · 18 commentaires ·

  • Add `:vanished` kwarg to `#fetch`/`#uid_fetch` (RFC7162, QRESYNC)
    Peut-être pris @nevans l’a pris il y a 433 jours. Ouverte

    Difficulté 4/5 3-5 jours Accessibilité débutants 15/100

    ruby/net-imap#131 ·

  • Add `:qresync` kwarg to `#select`, `#examine` (RFC7162)
    Peut-être pris @nevans l’a pris il y a 431 jours. Ouverte

    Difficulté 5/5 Plus d'une semaine Accessibilité débutants 15/100

    ruby/net-imap#123 ·

Recevez les nouvelles issues par e-mail

Un résumé court des issues GitHub adaptées aux débutants.