RFC4466 (2006): Collected Extensions to IMAP4 ABNF

Đang mở
#35 0 bình luận 0 reaction 0 người được giao Xem trên GitHub

Chưa có ai nhận issue này.

Đánh giá

Độ khó
5/5
Thời gian dự kiến
Hơn một tuần
Mức phù hợp với người mới
25/100
Loại issue
Tính năng
Độ rõ ràng
Cần làm rõ
Mức độ hoạt động
Đình trệ
Công nghệ
ruby
Lĩnh vực
networking

Hướng nghiên cứu

Bắt đầu bằng việc xem xét RFC4466, RFC3501 và RFC9051, sau đó kiểm tra các issue được liên kết còn tồn đọng (#123, #124–#131, #133 và #536–#537) để xác định phạm vi triển khai còn lại. Được xem là hoàn tất khi các mục parsing và mở rộng command của RFC4466 chưa được đánh dấu trong checklist này đã được triển khai và được các bài kiểm thử liên quan của dự án bao phủ.

Do mô hình lập chỉ mục viết ra từ nội dung của issue.

Mô tả

IMAP4rev2

Supporting RFC4466 as well as the basic ABNF in RFC3501 will give significant forward compatibility, allowing us to partially parse some other extensions which we don't (yet?) otherwise support. Additionally, RFC4466 support is necessary for RFC9051.

  • Parse unknown or unsupported extensions using RFC4466 tagged-ext syntax
    • Parse tagged-ext-val (done as part of #225)
    • Add ExtensionData (done as part of #225)
    • #127
    • #128
    • #129
      (also usable for non-RFC4466 extension data)
  • RFC4466 2.1: Optional Parameters with the #select/#examine Commands
    • #124
    • Add kwargs to #select/#examine for existing select-param extensions
      • #122
      • #123
  • RFC4466 2.2: Extended #create Command
    • #126
    • Add kwargs to #create for existing create-param extensions
      • #125
  • RFC4466 2.3: Extended #rename Command
    • #130
  • RFC4466 2.4: Extensions to #fetch and #uid_fetch Commands
    • #133
    • Add kwargs to #fetch/#uid_fetch for existing fetch-modifier extensions
      • #132
      • #131
  • RFC4422 2.6: Extensions to #search Command
    • #115
      • Add arbitrary return opts to #search, using search-return-opts syntax (RFC4466 tagged-ext)
    • #121
      • #120
      • Parse all existing search-return-data extensions directly
  • RFC4422 2.7: Extensions to #append Command
    • #535
    • #537
    • #536
Ngôn ngữ chính
Ruby
Star
121
Fork
47
Merge trung bình
19 giờ 25 phút
Pull request đã merge (30 ngày)
3

Chuẩn bị môi trường

Dự án này không cung cấp dev container, Dockerfile hay hướng dẫn đóng góp, nên bạn cần tự thiết lập môi trường: hãy bắt đầu từ README và xem hướng dẫn đóng góp lần đầu của chúng tôi để biết các bước chung.

Bắt đầu từ đâu

  1. Đọc hết issue, rồi đọc hướng dẫn đóng góp của dự án.
  2. Bình luận trên issue rằng bạn sẽ nhận — tránh hai người làm cùng một việc.
  3. Fork repository và làm thay đổi trên một nhánh.
  4. Mở pull request có tham chiếu số hiệu của issue.

Issue khác của ruby/net-imap

Tất cả issue của ruby/net-imap

Issue tương tự

Thêm issue về Ruby

Nhận issue mới trong hộp thư của bạn

Bản tóm tắt ngắn những issue GitHub phù hợp với người mới.