RFC5258 (2008): `LIST-EXTENDED` (mostly included in `IMAP4rev2`)
まだ誰も着手していません。
評価
調査の方向性
#list API から開始し、現在の処理を RFC4466 の tagged-ext 構文および RFC9051 の mbox-list-extended-item 要件と比較します。一覧にある select オプションと return オプションを実装し、既知および未知の拡張を TaggedExtensionData にパースして、完了したチェックリスト項目ごとに適切な対象テストを追加します。
索引モデルが issue の本文から書いたものです。
説明
RFC5258 also established an IANA registy.
- Add select options to
#list, using RFC4466tagged-extsyntax - Add return options to
#list, using RDC4466tagged-extsyntax - Parse all RFC9051
mbox-list-extended-itemdirectly- TODO: add appropriate tickets here...
- Parse all other
mbox-list-extended-itemextensions directly- TODO: add appropriate tickets here...
- Parse unknown
mbox-list-extendedinto TaggedExtensionData
- 主要言語
- Ruby
- スター
- 121
- フォーク
- 47
- 平均マージ
- 19時間 25分
- マージ済み PR(30日)
- 3
環境構築
このプロジェクトには開発コンテナ、Dockerfile、コントリビューションガイドがありません。まず README を読み、一般的な手順ははじめてのコントリビューションガイドを参照してください。
はじめの一歩
- issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
- 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
- リポジトリをフォークし、ブランチを切って変更します。
- issue 番号を参照したプルリクエストを送ります。
ruby/net-imap のほかの issue
-
難易度 2/5 1〜3時間 初心者へのやさしさ 77/100
-
bug
難易度 5/5 1週間以上 初心者へのやさしさ 30/100
-
難易度 3/5 1〜2日 初心者へのやさしさ 25/100
-
難易度 5/5 1週間以上 初心者へのやさしさ 15/100
-
難易度 5/5 1週間以上 初心者へのやさしさ 20/100
似ている issue
-
難易度 2/5 1〜3時間 初心者へのやさしさ 74/100
メンテナーはふだん 1 日以内に返信
-
Websockify heartbeat for vnc_container対応中かも @robinkar が今日担当しました。 オープン
難易度 2/5 1〜3時間 初心者へのやさしさ 76/100
メンテナーはふだん 1 日以内に返信
-
needs verification
難易度 2/5 1〜3時間 初心者へのやさしさ 68/100
メンテナーはふだん 7 日以内に返信
-
難易度 1/5 1時間未満 初心者へのやさしさ 88/100
akitaonrails/ai-book-2026#13 ·
-
Mend: dependency security vulnerability
難易度 2/5 1〜3時間 初心者へのやさしさ 63/100
メンテナーはふだん 1 日以内に返信