Update @expo/plist to suppress a warning?
还没有人认领这个 Issue。
评估
- 难度
- 2/5
- 预计耗时
- 1-3 小时
- 新手友好度
- 78/100
- Issue 类型
- 重构
- 描述清晰度
- 描述清楚
- 活跃度
- 冷清
- 技术栈
- typescript
- 领域
- build-system
调研方向
先查看包清单和锁定文件,定位 @expo/plist 0.0.x 依赖项,然后将其更新到 0.4.8,并更新对应的 @xmldom/xmldom 版本。运行 yarn test 并复现全局 npm install 警告,以验证已弃用的依赖项已移除,并且现有测试仍然通过。
由索引模型根据 Issue 内容生成。
描述
Hi,
This package currently relies on @expo/plist 0.0.x, which is quite outdated, as the latest version is 0.4.8.
The problem is that @expo/plist 0.0.x depends on @xmldom/xmldom 0.7.x, which is no longer officially supported. When I install my package that depends on @bacons/xcode using npm install -g, I receive the following warning:
npm WARN deprecated @xmldom/[email protected]: this version is no longer supported, please update to at least 0.8.*
Would it be possible to update @expo/plist to the latest version, which uses xmldom 0.8.x? I quickly updated it and ran yarn test on my end, and no test cases failed, so the update might be straightforward.
Lastly, thanks for maintaining this awesome project. I really appreciate your work.
Edit (2026/05/23): As a temporary workaround, I created another npm package called @mshibanami-org/xcode. The forked source code is here: https://github.com/mshibanami/xcode. Use it if you want.
- 主要语言
- TypeScript
- 星标
- 224
- 派生
- 14
- PR 合并指标
- 30 天内没有已合并 PR
环境准备
这个项目没有提供开发容器、Dockerfile 或贡献指南,环境需要你自己搭建:先看它的 README,通用步骤见我们的新手贡献指南。
从这里开始
- 先读完整个 Issue,再读项目的贡献指南。
- 在 Issue 下留言说明你要接手 —— 这能避免两个人做同样的事。
- Fork 仓库,在一个分支上完成修改。
- 提交 Pull Request,并在描述里引用这个 Issue 编号。
相似的 Issue
-
area:cli bug P4
难度 2/5 1-3 小时 新手友好度 82/100
维护者通常 1 天内回复
-
bug from-studio
难度 2/5 1-3 小时 新手友好度 65/100
esengine/DeepSeek-Reasonix#14868 ·
维护者通常 1 天内回复
-
难度 2/5 1-3 小时 新手友好度 68/100
维护者通常 1 天内回复
-
bug
难度 2/5 1-3 小时 新手友好度 72/100
loopbackio/loopback-next#11878 ·
维护者通常 2 天内回复
-
bug 🐛
难度 2/5 1-3 小时 新手友好度 78/100
comunica/comunica#1925 · 1 条评论 ·
维护者通常 1 天内回复