Hacktoberfest 2026:メンテナが10月に向けて印を付けた、オープンで初心者向けの issue。 Hacktoberfest の issue を見る

Update @expo/plist to suppress a warning?

オープン 初心者向け
#32 コメント 3 件 リアクション 7 件 担当者 0 名 GitHub で見る

まだ誰も着手していません。

評価

難易度
2/5
見積もり時間
1〜3時間
初心者へのやさしさ
78/100
issue の種類
リファクタリング
明瞭さ
明確に書かれている
活発さ
静か
技術スタック
typescript
領域
build-system

調査の方向性

パッケージマニフェストとロックファイルを確認し、@expo/plist の 0.0.x 依存関係を特定します。次に,将其更新为 0.4.8,并更新对应的 @xmldom/xmldom 版本。yarn test を実行し、グローバルな npm install の警告を再現して、非推奨の依存関係が解消され、既存のテストが引き続き成功することを確認します。

索引モデルが issue の本文から書いたものです。

説明

Hi,

This package currently relies on @expo/plist 0.0.x, which is quite outdated, as the latest version is 0.4.8.

The problem is that @expo/plist 0.0.x depends on @xmldom/xmldom 0.7.x, which is no longer officially supported. When I install my package that depends on @bacons/xcode using npm install -g, I receive the following warning:

npm WARN deprecated @xmldom/[email protected]: this version is no longer supported, please update to at least 0.8.*

Would it be possible to update @expo/plist to the latest version, which uses xmldom 0.8.x? I quickly updated it and ran yarn test on my end, and no test cases failed, so the update might be straightforward.

Lastly, thanks for maintaining this awesome project. I really appreciate your work.


Edit (2026/05/23): As a temporary workaround, I created another npm package called @mshibanami-org/xcode. The forked source code is here: https://github.com/mshibanami/xcode. Use it if you want.

主要言語
TypeScript
スター
224
フォーク
14
PR マージ指標
30日以内にマージされた PR はありません

環境構築

このプロジェクトには開発コンテナ、Dockerfile、コントリビューションガイドがありません。まず README を読み、一般的な手順ははじめてのコントリビューションガイドを参照してください。

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

似ている issue

TypeScript の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。