DHCP Configuration concept
Chưa có ai nhận issue này.
Đánh giá
- Độ khó
- 5/5
- Thời gian dự kiến
- Hơn một tuần
- Mức phù hợp với người mới
- 25/100
- Loại issue
- Tính năng
- Độ rõ ràng
- Khá rõ ràng
- Mức độ hoạt động
- Đình trệ
- Công nghệ
- grpc
- Lĩnh vực
- api, backend-api-design, networking
Hướng nghiên cứu
Bắt đầu bằng việc đọc RFC 2132, RFC 3004 và RFC 3442, sau đó xem xét các cách tiếp cận API GRPC hiện có của ironcore(-net), metalnet và dpservice. Xác định các tùy chọn DHCP được chọn, các khái niệm API và hành vi tương thích ngược ở cả hai lớp API. Được xem là hoàn thành khi các tiêu chí chấp nhận của networking và ironcore-api được ghi lại mà không triển khai tính năng.
Do mô hình lập chỉ mục viết ra từ nội dung của issue.
Mô tả
Summary
Currently DHCP(v6) configuration possibilities like DNS Server IP, hostname, DNS search domain, FQDN, NTP Server Ip etc.
are not all offered and the ones which are offered are not centrally configurable by the ironcore API user.
There is a need to identify an unified way of handling DHCP related configurations/settings effecting the created
ironcore VMs and Metal Machines.
Scope
✅ In Scope
- Research the relevant RFCs like RFC 2132, 3004, 3442 for DHCPv4 and DHCPv6 to determine the configurations which can be offered
to ironcore API users. - Define a concept together with ironcore API. Define the ironcore(-net) / metalnet layer API. Define possible dpservice GRPC changes.
- Make sure that the new concept is backward compatible with the current approach that is being used.
❌ Out of Scope
- Full Coverage of All Possible DHCP Options: Only a subset of DHCP options relevant to ironcore VM and metal machine provisioning will be considered. Full support for the entire range of options defined in the RFCs is not targeted.
- Implementation is not part of this work.
Responsible Areas
- Networking
- ironcore-api
Contributors
- @afritzler
- @guvenc
- @byteocean
- @MalteJ
Acceptance Criteria
-
Networking
- A clear concept on metalnet and dpservice GRPC API level defined.
- Each needed DHCP option is reflected on low level API.
- Backward compatibility on metalnet / dpservice level defined.
-
ironcore-api
- A clear concept on ironcore(-net) API level defined.
- Each needed DHCP option is identified.
- Backward compatibility on ironcore(-net) defined.
Action Items
- Assign labels (e.g.,
area/ironcore-api,kind/design) - Set milestone (e.g.,
H1/2025) - Assign dependent sub-issues in each required area
- Assign an owner to the issue using the GitHub "Assignee" field
- List all contributors in the "Contributors" section above
- Add this issue to the
Roadmapproject board
- Ngôn ngữ chính
- Shell
- Star
- 1
- Fork
- 1
- Chỉ số merge pull request
- Không có pull request nào được merge trong 30 ngày
Chuẩn bị môi trường
Dự án này không cung cấp dev container, Dockerfile hay hướng dẫn đóng góp, nên bạn cần tự thiết lập môi trường: hãy bắt đầu từ README và xem hướng dẫn đóng góp lần đầu của chúng tôi để biết các bước chung.
Bắt đầu từ đâu
- Đọc hết issue, rồi đọc hướng dẫn đóng góp của dự án.
- Bình luận trên issue rằng bạn sẽ nhận — tránh hai người làm cùng một việc.
- Fork repository và làm thay đổi trên một nhánh.
- Mở pull request có tham chiếu số hiệu của issue.
Issue khác của ironcore-dev/roadmap
-
Clean up IronCore repoCó thể làm lại được @lukasfrank đã nhận 54 ngày trước và không có pull request nào đang mở. Đang mởarea/iaas kind/roadmap
ironcore-dev/roadmap#129 · 1 người được giao ·
-
area/compute area/iaas kind/roadmap
Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 30/100
ironcore-dev/roadmap#128 ·
-
NAT64/NAT46 with High Performance and FlexibilityCó thể làm lại được @byteocean đã nhận 74 ngày trước và không có pull request nào đang mở. Đang mởarea/networking kind/roadmap
ironcore-dev/roadmap#126 · 1 người được giao ·
-
Observability Specification for IronCore componentsCó thể làm lại được @peanball đã nhận 103 ngày trước và không có pull request nào đang mở. Đang mởarea/product kind/roadmap
ironcore-dev/roadmap#123 · 1 người được giao ·
-
IronCore DNS Service (static / manually configured entries)Có thể làm lại được @peanball đã nhận 107 ngày trước và không có pull request nào đang mở. Đang mởarea/iaas area/ironcore-api area/networking kind/roadmap
ironcore-dev/roadmap#122 · 1 người được giao ·
Tất cả issue của ironcore-dev/roadmap
Issue tương tự
-
Isha NarulaĐang mở
Độ khó 1/5 Dưới một giờ Mức phù hợp với người mới 72/100
dataplat/DataSpeakers#178 ·
-
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 78/100
btclib-org/claude-process#341 ·
-
command: start distro: Debian engine: null game: Teamspeak 3 reproducible: always severity: low type: bug
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 76/100
GameServerManagers/LinuxGSM#5193 ·
Maintainer thường phản hồi trong vòng 1 ngày
-
install: a relative or space-containing --tools-home writes a hook that cannot run, with no warningĐang mởbug
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 75/100
Maintainer thường phản hồi trong vòng 1 ngày
-
[BUG] mo clean deletes Cypress test runner binaries in ~/Library/Caches/CypressCó thể đã có người làm @viniciusdsandrade đã nhận hôm nay. Đang mở
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 78/100
Maintainer thường phản hồi trong vòng 1 ngày