DHCP Configuration concept

オープン
#68 コメント 2 件 リアクション 0 件 担当者 0 名 GitHub で見る

まだ誰も着手していません。

評価

難易度
5/5
見積もり時間
1週間以上
初心者へのやさしさ
25/100
issue の種類
機能追加
明瞭さ
おおむね明確
活発さ
停滞
技術スタック
grpc

調査の方向性

まず RFC 2132、RFC 3004、RFC 3442 を読み、その後、既存の ironcore(-net)、metalnet、dpservice の GRPC API アプローチを確認します。選択した DHCP オプション、API の概念、および両方の API レイヤーにおける後方互換性の動作を定義します。完了の条件は、機能を実装せずに networking と ironcore-api の受け入れ基準が文書化されていることです。

索引モデルが issue の本文から書いたものです。

説明

area/iaas area/networking

Summary

Currently DHCP(v6) configuration possibilities like DNS Server IP, hostname, DNS search domain, FQDN, NTP Server Ip etc.
are not all offered and the ones which are offered are not centrally configurable by the ironcore API user.
There is a need to identify an unified way of handling DHCP related configurations/settings effecting the created
ironcore VMs and Metal Machines.


Scope

✅ In Scope
  • Research the relevant RFCs like RFC 2132, 3004, 3442 for DHCPv4 and DHCPv6 to determine the configurations which can be offered
    to ironcore API users.
  • Define a concept together with ironcore API. Define the ironcore(-net) / metalnet layer API. Define possible dpservice GRPC changes.
  • Make sure that the new concept is backward compatible with the current approach that is being used.
❌ Out of Scope
  • Full Coverage of All Possible DHCP Options: Only a subset of DHCP options relevant to ironcore VM and metal machine provisioning will be considered. Full support for the entire range of options defined in the RFCs is not targeted.
  • Implementation is not part of this work.

Responsible Areas

  • Networking
  • ironcore-api

Contributors

  • @afritzler
  • @guvenc
  • @byteocean
  • @MalteJ

Acceptance Criteria

  • Networking
    • A clear concept on metalnet and dpservice GRPC API level defined.
    • Each needed DHCP option is reflected on low level API.
    • Backward compatibility on metalnet / dpservice level defined.
  • ironcore-api
    • A clear concept on ironcore(-net) API level defined.
    • Each needed DHCP option is identified.
    • Backward compatibility on ironcore(-net) defined.

Action Items

  • Assign labels (e.g., area/ironcore-api, kind/design)
  • Set milestone (e.g., H1/2025)
  • Assign dependent sub-issues in each required area
  • Assign an owner to the issue using the GitHub "Assignee" field
  • List all contributors in the "Contributors" section above
  • Add this issue to the Roadmap project board
主要言語
Shell
スター
1
フォーク
1
PR マージ指標
30日以内にマージされた PR はありません

環境構築

このプロジェクトには開発コンテナ、Dockerfile、コントリビューションガイドがありません。まず README を読み、一般的な手順ははじめてのコントリビューションガイドを参照してください。

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

ironcore-dev/roadmap のほかの issue

ironcore-dev/roadmap の issue をすべて見る

似ている issue

Shell/Bash の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。