Updates minimum supported Flutter >=3.47.0 and Dart ^3.13.0.

Open
#549 0 comments 0 reactions 0 assignees View on GitHub

Maintainers usually reply within 1 day

Nobody has claimed this yet.

Assessment

Difficulty
3/5
Estimated time
1-2 days
Newbie friendliness
48/100
Issue type
Refactor
Clarity
Mostly clear
Activity status
Quiet
Tech stack
android, dart, swift

Research direction

Start with the example Android project’s Gradle, Java, Kotlin, and AGP configuration, then inspect how the package currently declares support for Swift Package Manager. Update the minimum Flutter and Dart versions and Android toolchain to the versions listed, and add Swift Package Manager support. Done means the example builds with Java 17, KGP 2.4.0, AGP 9.1.0, and Gradle 9.3.1, and the package can be consumed through Swift Package Manager.

Written by the indexing model from the issue text.

Description

  • Updates example Android project for Flutter 3.47
  1. Java: 17 (minimum required version)
  2. Kotlin Gradle Plugin (KGP): 2.4.0
  3. Android Gradle Plugin (AGP): 9.1.0 (newest compatible with KGP 2.4.0)
  4. Gradle: 9.3.1 (minimum required for AGP 9.1.0)
  • Add Swift Package Manager support
Dominant language
Dart
Stars
2.9k
Forks
646
Avg merge
5m
Merged PRs (30d)
9

Getting set up

This project ships no dev container, Dockerfile or contributing guide, so setting up is up to you: start from its README, and see our first-contribution guide for the general steps.

First steps

  1. Read the whole issue, then the project's contributing guide.
  2. Comment on the issue to say you are picking it up — it saves two people doing the same work.
  3. Fork the repository and make your change on a branch.
  4. Open a pull request that references the issue number.

More from letsar/flutter_slidable

All issues in letsar/flutter_slidable

Similar issues

More Dart issues

Get new issues in your inbox

A short digest of beginner-friendly GitHub issues.