Updates minimum supported Flutter >=3.47.0 and Dart ^3.13.0.

オープン
#549 コメント 0 件 リアクション 0 件 担当者 0 名 GitHub で見る

メンテナーはふだん 1 日以内に返信

まだ誰も着手していません。

評価

難易度
3/5
見積もり時間
1〜2日
初心者へのやさしさ
48/100
issue の種類
リファクタリング
明瞭さ
おおむね明確
活発さ
静か
技術スタック
android, dart, swift

調査の方向性

Start with the example Android project’s Gradle, Java, Kotlin, and AGP configuration, then inspect how the package currently declares support for Swift Package Manager. Update the minimum Flutter and Dart versions and Android toolchain to the versions listed, and add Swift Package Manager support. Done means the example builds with Java 17, KGP 2.4.0, AGP 9.1.0, and Gradle 9.3.1, and the package can be consumed through Swift Package Manager.

索引モデルが issue の本文から書いたものです。

説明

  • Updates example Android project for Flutter 3.47
  1. Java: 17 (minimum required version)
  2. Kotlin Gradle Plugin (KGP): 2.4.0
  3. Android Gradle Plugin (AGP): 9.1.0 (newest compatible with KGP 2.4.0)
  4. Gradle: 9.3.1 (minimum required for AGP 9.1.0)
  • Add Swift Package Manager support
主要言語
Dart
スター
2.9k
フォーク
646
平均マージ
5分
マージ済み PR(30日)
9

環境構築

このプロジェクトには開発コンテナ、Dockerfile、コントリビューションガイドがありません。まず README を読み、一般的な手順ははじめてのコントリビューションガイドを参照してください。

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

letsar/flutter_slidable のほかの issue

letsar/flutter_slidable の issue をすべて見る

似ている issue

Dart の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。