v4 'cachePath' with absolute path
@jszuminski 已经在做这个了。
开始于 2024年9月2日。
评估
这个 Issue 还没有评估数据。
描述
Expected behaviour
highcharts.cachePath or HIGHCHARTS_CACHE_PATH env var should allow an absolute path such as '/tmp/.cache'
Actual behaviour
Previously (v3) if the manifest.json file existed in the 'node_modules/highcharts-export-server/.cache' directory but read-only it would log an error and initPool would continue to start. Now initExport throws an error.
Reproduction steps
Set the 'node_modules/highcharts-export-server/.cache/manifest.json' file as read-only and initExport will throw an error.
Ideally just allow cachePath to specify an absolute path and if the manifest.json file exists (and un-changed) then skip writing new manifest
- 主要语言
- JavaScript
- 星标
- 368
- 派生
- 265
- PR 合并指标
- 30 天内没有已合并 PR
环境准备
- 提供 Dockerfile 或 Docker Compose 文件
- 没有 Pull Request 模板
- 没有贡献指南
从这里开始
- 先读完整个 Issue,再读项目的贡献指南。
- 在 Issue 下留言说明你要接手 —— 这能避免两个人做同样的事。
- Fork 仓库,在一个分支上完成修改。
- 提交 Pull Request,并在描述里引用这个 Issue 编号。
highcharts/node-export-server 的其他 Issue
-
Update Puppeteer to version 25.11.0+ to allow ARM64 linux images to run node-export-server可能已有人在做 @daniatic 于 4 天前认领。 未关闭
难度 2/5 1-3 小时 新手友好度 75/100
highcharts/node-export-server#686 ·
-
难度 3/5 1-2 天 新手友好度 35/100
highcharts/node-export-server#680 · 1 条评论 ·
-
难度 5/5 一周以上 新手友好度 25/100
highcharts/node-export-server#679 ·
-
难度 3/5 1-2 天 新手友好度 45/100
highcharts/node-export-server#678 ·
-
难度 4/5 3-5 天 新手友好度 30/100
highcharts/node-export-server#676 ·
查看 highcharts/node-export-server 的全部 Issue
相似的 Issue
-
难度 2/5 1-3 小时 新手友好度 62/100
维护者通常 1 天内回复
-
难度 2/5 1-3 小时 新手友好度 65/100
rescript-lang/rescript-lang.org#1415 ·
维护者通常 2 天内回复
-
[Bug]: agent capture drops long Unicode text as punctuation可能已有人在做 @ktz03 今天认领。 未关闭
难度 2/5 1-3 小时 新手友好度 82/100
volcengine/OpenViking#5801 ·
维护者通常 1 天内回复
-
bug
难度 2/5 1-3 小时 新手友好度 85/100
Deepak3699/Ai_Mentor#244 ·
维护者通常 1 天内回复
-
难度 2/5 1-3 小时 新手友好度 78/100
nextcloud/collectives#2843 ·
维护者通常 1 天内回复