Upgrade commons-codec:commons-codec to 1.14 or higher to fix security vulnerability

未关闭
#896 1 条评论 0 个 reaction 已指派 1 人 在 GitHub 查看

维护者通常 1 天内回复

@hemasekhar-p 已经在做这个了。

开始于 2026年3月24日。

  • #1367 来自 @copybara-service —— 未关闭

评估

这个 Issue 还没有评估数据。

描述

priority: p2 type: bug

The security vulnerability tool Snyk identifies a security issue with java-genai using commons-codec:[email protected] (which was released on Oct 17, 2017, so 8.5 years ago). From the listing:

commons-codec:commons-codec is a package that contains simple encoder and decoders for various formats such as Base64 and Hexadecimal.

Affected versions of this package are vulnerable to Information Exposure. When there is no byte array value that can be encoded into a string the Base32 implementation does not reject it, and instead decodes it into an arbitrary value which can be re-encoded again using the same implementation. This allows for information exposure exploits such as tunneling additional information via seemingly valid base 32 strings.

Snyk recommends upgrading to version 1.14 or higher. The latest version of commons-codec:commons-codec as of this writing is 1.21.0, released January 30, 2026.

主要语言
Java
星标
398
派生
126
平均合并
1 天 12 小时
30 天内合并 PR
71

环境准备

  • 没有 Dockerfile 或 Docker Compose 文件
  • 没有 Pull Request 模板
  • 阅读贡献指南

从这里开始

  1. 先读完整个 Issue,再读项目的贡献指南。
  2. 在 Issue 下留言说明你要接手 —— 这能避免两个人做同样的事。
  3. Fork 仓库,在一个分支上完成修改。
  4. 提交 Pull Request,并在描述里引用这个 Issue 编号。

googleapis/java-genai 的其他 Issue

查看 googleapis/java-genai 的全部 Issue

相似的 Issue

更多 Java Issue

把新 issue 发到你的邮箱

精选适合新手参与的 GitHub issue 摘要。