CVE-2026-54696 (Low) detected in json-2.12.2.gem
还没有人认领这个 Issue。
评估
调研方向
先从 Gemfile.lock 和 vendor/cache/json-2.12.2.gem 中的 vendored dependency 入手,然后检查此 repository 如何管理 Ruby gem 升级。将 json 更新到指定的固定版本 2.19.9,按需刷新 lockfile 和 vendored package,并运行 repository 的测试套件,以确认依赖项变更没有问题。
由索引模型根据 Issue 内容生成。
描述
CVE-2026-54696 - Low Severity Vulnerability
Vulnerable Library - json-2.12.2.gem
This is a JSON implementation as a Ruby extension in C.
Library home page: https://rubygems.org/gems/json-2.12.2.gem
Path to dependency file: /Gemfile.lock
Path to vulnerable library: /vendor/cache/json-2.12.2.gem
Dependency Hierarchy:
- rubocop-1.76.1.gem (Root Library)
- ❌ json-2.12.2.gem (Vulnerable Library)
Found in base branch: master
Vulnerability Details
Ruby JSON is a JSON implementation for Ruby. Versions 2.9.0 through 2.19.8 are vulnerable to heap buffer overflow when the JSON generator is provided with an oversized streamed object. When streaming to an IO JSON.dump(obj, io) and JSON::State#generate(obj, io) can write past the internal JSON generator buffer when a streamed object contains an
attacker-controlled string near 16 KB. Exploitation would result in a reliable process crash/denial of service. This issue has been fixed in version 2.19.9.
Publish Date: 2026-06-30
URL: CVE-2026-54696
CVSS 3 Score Details (3.7)
Base Score Metrics:
- Exploitability Metrics:
- Attack Vector: Network
- Attack Complexity: High
- Privileges Required: None
- User Interaction: None
- Scope: Unchanged
- Impact Metrics:
- Confidentiality Impact: None
- Integrity Impact: None
- Availability Impact: Low
Suggested Fix
Type: Upgrade version
Origin: https://github.com/ruby/json/security/advisories/GHSA-x2f5-4prf-w687
Release Date: 2026-06-30
Fix Resolution: json - 2.19.9
Step up your Open Source Security Game with Mend here
- 主要语言
- Ruby
- 星标
- 30
- 派生
- 27
- PR 合并指标
- 30 天内没有已合并 PR
环境准备
- 没有 Dockerfile 或 Docker Compose 文件
- 没有 Pull Request 模板
- 阅读贡献指南
从这里开始
- 先读完整个 Issue,再读项目的贡献指南。
- 在 Issue 下留言说明你要接手 —— 这能避免两个人做同样的事。
- Fork 仓库,在一个分支上完成修改。
- 提交 Pull Request,并在描述里引用这个 Issue 编号。
ManageIQ/linux_admin 的其他 Issue
-
Mend: dependency security vulnerability
难度 2/5 1-3 小时 新手友好度 75/100
ManageIQ/linux_admin#290 ·
-
Mend: dependency security vulnerability
难度 2/5 1-3 小时 新手友好度 72/100
ManageIQ/linux_admin#289 ·
-
Mend: dependency security vulnerability
难度 2/5 1-3 小时 新手友好度 68/100
ManageIQ/linux_admin#288 ·
-
Mend: dependency security vulnerability
难度 2/5 1-3 小时 新手友好度 76/100
ManageIQ/linux_admin#286 ·
-
Mend: dependency security vulnerability
难度 2/5 1-3 小时 新手友好度 75/100
ManageIQ/linux_admin#285 ·
查看 ManageIQ/linux_admin 的全部 Issue
相似的 Issue
-
verified
难度 2/5 1-3 小时 新手友好度 67/100
维护者通常 5 天内回复
-
难度 1/5 1 小时以内 新手友好度 86/100
akitaonrails/ai-book-2026#10 ·
-
难度 2/5 1-3 小时 新手友好度 76/100
zerocracy/judges-action#2984 ·
维护者通常 1 天内回复