/run seems not to have correct rights
Chưa có ai nhận issue này.
Đánh giá
- Độ khó
- 3/5
- Thời gian dự kiến
- 1-2 ngày
- Mức phù hợp với người mới
- 45/100
- Loại issue
- Lỗi
- Độ rõ ràng
- Cần làm rõ
- Mức độ hoạt động
- Ít trao đổi
- Công nghệ
- docker
- Lĩnh vực
- devops
Hướng nghiên cứu
Bắt đầu bằng cách kiểm tra cách container tạo /run/plex-temp và thiết lập quyền, sau đó tái hiện bằng docker restart plex với image mới nhất trong Portainer. So sánh các quyền nhận được với workaround chmod 755 /run đã được báo cáo và xác minh rằng Plex khởi động mà không gặp crash do bị từ chối quyền.
Do mô hình lập chỉ mục viết ra từ nội dung của issue.
Mô tả
Is there an existing issue for this?
- I have searched the existing issues
Current Behavior
1.43.2.10687-563d026ea
in container bash:
# namei -om /run/plex-temp
f: /run/plex-temp
drwxr-xr-x root root /
drwxr-xr-- root root run
drwxr-xr-x abc users plex-temp
and running:
chmod 755 /run
fixed it
just for info: running the plex image in portainer under OMV
Expected Behavior
No response
Steps To Reproduce
docker restart plex
and the permissions are gone again
Environment
- OS:
- How docker service was installed:
CPU architecture
x86-64
Docker creation
just using the latest image creation in portainer
Container logs
Starting Plex Media Server. . . (you can ignore the libusb_init error)
libc++abi: terminating with uncaught exception of type std::runtime_error: Codecs: Initialize: 'boost::filesystem::status: Permission denied [system:13]: "/run/plex-temp"'
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.43.2.10687-563d026ea/PLEX MEDIA SERVER/4a79c970-997c-40ff-6dbcb9a5-eca347d1.
- Ngôn ngữ chính
- Dockerfile
- Star
- 1.4k
- Fork
- 228
- Chỉ số merge pull request
- Không có pull request nào được merge trong 30 ngày
Hướng dẫn đóng góp
Bắt đầu từ đâu
- Đọc hết issue, rồi đọc hướng dẫn đóng góp của dự án.
- Bình luận trên issue rằng bạn sẽ nhận — tránh hai người làm cùng một việc.
- Fork repository và làm thay đổi trên một nhánh.
- Mở pull request có tham chiếu số hiệu của issue.
Issue khác của linuxserver/docker-plex
-
no-issue-activity
Độ khó 1/5 Dưới một giờ Mức phù hợp với người mới 92/100
linuxserver/docker-plex#458 · 2 bình luận ·
-
work-in-progress
Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 35/100
linuxserver/docker-plex#432 · 27 bình luận ·
Tất cả issue của linuxserver/docker-plex
Issue tương tự
-
kind/bug needs-triage
Độ khó 1/5 Dưới một giờ Mức phù hợp với người mới 72/100
matrixorigin/matrixone#29223 ·
-
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 84/100
copse-dev/agent-pane#2953 ·
-
bug ci-failure high priority
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 74/100
vllm-project/vllm-omni#7972 · 1 bình luận ·
-
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 90/100
simonw/sqlite-utils#872 ·
-
bug good first issue
Độ khó 1/5 Dưới một giờ Mức phù hợp với người mới 88/100
amponce/archive-movie-browser#166 ·