[BUG] `BothV()` not supported in Gremlin in Calcite-based Compiler
Chưa có ai nhận issue này.
Đánh giá
- Độ khó
- 4/5
- Thời gian dự kiến
- 3-5 ngày
- Mức phù hợp với người mới
- 35/100
Hướng nghiên cứu
Tái hiện truy vấn Gremlin trên tập dữ liệu lsqb với cấu hình planner được liệt kê, sau đó so sánh các logical plan và physical plan được hiển thị trong issue. Theo dõi đường dẫn compiler xử lý bothV() và xác minh quá trình hoàn tất khi physical plan bao gồm operator GetV còn thiếu và trả về các vertex thay vì edge.
Do mô hình lập chỉ mục viết ra từ nội dung của issue.
Mô tả
Describe the bug
A clear and concise description of what the bug is.
As titled.
Below is an example query on lsqb dataset that illustrates the problem:
gremlin> g.V().hasLabel("city").has("id", 111).bothE("isLocatedIn").bothV()
==>e[48167737][72088380363509640-isLocatedIn->648518346341351535]
==>e[48167890][72092778410023144-isLocatedIn->648518346341351535]
==>e[48169242][72066390130974264-isLocatedIn->648518346341351535]
==>e[48170302][72057594037953336-isLocatedIn->648518346341351535]
==>e[48170858][72092778410022784-isLocatedIn->648518346341351535]
==>e[48171593][72092778410034236-isLocatedIn->648518346341351535]
...
, where bothV() is ignored.
The logical plan looks like:
GraphLogicalProject($f0=[_], isAppend=[false])
GraphLogicalExpand(tableConfig=[{isAll=false, tables=[isLocatedIn]}], alias=[_], opt=[BOTH])
GraphLogicalSource(tableConfig=[{isAll=false, tables=[city]}], alias=[_], fusedFilter=[[=(_.id, 111)]], opt=[VERTEX])
and the physical plan looks like:
operations: [
PhysicalOpr {
opr: Scan(
Scan {
scan_opt: Vertex,
...
}
PhysicalOpr {
opr: Repartition(
Repartition {
strategy: Some(
ToAnother(
Shuffle {
shuffle_key: None,
},
),
),
},
),
},
PhysicalOpr {
opr: Edge(
EdgeExpand {
v_tag: None,
direction: Both,
params: Some(
QueryParams {
tables: [
NameOrId {
item: Some(
Id(
11,
),
),
},
],
columns: [],
is_all_columns: false,
limit: None,
predicate: None,
sample_ratio: 1.0,
extra: {},
},
),
alias: None,
expand_opt: Edge,
is_optional: false,
},
),
},
PhysicalOpr {
opr: Project(
Project {
...})}
which miss the GetV operator for bothV().
To reproduce, compiler configuration is as follows:
graph.planner.is.on=true
graph.planner.opt=RBO
graph.planner.rules=FilterIntoJoinRule, FilterMatchRule, ExtendIntersectRule, ExpandGetVFusionRule
graph.physical.opt=proto
gremlin.script.language.name=antlr_gremlin_calcite
- Ngôn ngữ chính
- C++
- Star
- 3.6k
- Fork
- 470
- Chỉ số merge pull request
- Không có pull request nào được merge trong 30 ngày
Chuẩn bị môi trường
Khởi chạy dev container của dự án ngay trên trình duyệt, bằng tài khoản GitHub của bạn.
- Không có Dockerfile hay tệp Docker Compose
- Có mẫu pull request
- Đọc hướng dẫn đóng góp
Bắt đầu từ đâu
- Đọc hết issue, rồi đọc hướng dẫn đóng góp của dự án.
- Bình luận trên issue rằng bạn sẽ nhận — tránh hai người làm cùng một việc.
- Fork repository và làm thay đổi trên một nhánh.
- Mở pull request có tham chiếu số hiệu của issue.
Issue khác của alibaba/GraphScope
-
[BUG] Failed archive extraction deletes the dataset cacheCó thể đã có người làm @dajiaohuang đã nhận 9 ngày trước. Đang mở
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 78/100
alibaba/GraphScope#4674 ·
-
Please add multi-tenancyĐang mởstale
Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 25/100
alibaba/GraphScope#4655 · 2 bình luận ·
-
stale
Độ khó 5/5 Hơn một tuần Mức phù hợp với người mới 38/100
alibaba/GraphScope#4654 · 2 bình luận ·
-
stale
Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 45/100
alibaba/GraphScope#4647 · 3 bình luận ·
-
[BUG] IC14无法用Cypher执行Đang mởstale
Độ khó 4/5 3-5 ngày Mức phù hợp với người mới 30/100
alibaba/GraphScope#4639 · 2 bình luận ·
Tất cả issue của alibaba/GraphScope
Issue tương tự
-
Bug
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 72/100
Maintainer thường phản hồi trong vòng 1 ngày
-
Độ khó 1/5 Dưới một giờ Mức phù hợp với người mới 82/100
-
v3: Lua m.setvar() returns -1 on errors, so the script gets stack garbageCó thể đã có người làm Có pull request liên kết đang mở hoặc đã được merge. Đang mở3.x bug
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 72/100
owasp-modsecurity/ModSecurity#3731 ·
Maintainer thường phản hồi trong vòng 1 ngày
-
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 72/100
Sendspin/sendspin-cpp-cli#111 ·
Maintainer thường phản hồi trong vòng 1 ngày
-
[Core/Config] The server fails to start due to an invalid config path when debuggingCó thể đã có người làm Có pull request liên kết đang mở hoặc đã được merge. Đang mở
Độ khó 2/5 1-3 giờ Mức phù hợp với người mới 62/100
azerothcore/azerothcore-wotlk#28350 ·
Maintainer thường phản hồi trong vòng 1 ngày