Require react-native-blob-util >=1.0.0 (Xcode 27 iOS build failure)

Open Beginner friendly
#1,617 0 comments 0 reactions 0 assignees View on GitHub

Maintainers usually reply within 1 day

Nobody has claimed this yet.

Assessment

Difficulty
1/5
Estimated time
1-3 hours
Newbie friendliness
78/100
Issue type
Bug
Clarity
Clearly specified
Activity status
Active
Tech stack
react-native, typescript
Domain
mobile

Research direction

Find where the react-native-blob-util peer dependency and installation command are declared. Update the peer requirement to >=1.0.0 and pin version 1.0.0 in the install command. Done means the dependency declarations match the requested version and the iOS build failure described in the issue is addressed.

Written by the indexing model from the issue text.

Description

dependencies platform: ios

react-native-blob-util 0.25.1 (current latest) declares iOS 11.0; Xcode 27 rejects its privacy-bundle target ("deployment target ... is set to 11.0, but the range ... is 15.0 to 27.2.x"). Breaks bare RN and Expo 55. 1.0.0 builds and passes with RNE on both platforms. Raise the peer to >=1.0.0 and pin it in the install command.

Dominant language
TypeScript
Stars
1.8k
Forks
101
Avg merge
2d 4h
Merged PRs (30d)
58

Getting set up

First steps

  1. Read the whole issue, then the project's contributing guide.
  2. Comment on the issue to say you are picking it up — it saves two people doing the same work.
  3. Fork the repository and make your change on a branch.
  4. Open a pull request that references the issue number.

More from software-mansion/react-native-executorch

All issues in software-mansion/react-native-executorch

Similar issues

More TypeScript issues

Get new issues in your inbox

A short digest of beginner-friendly GitHub issues.