Yarn command gates use the launcher version instead of the version selected by yarnPath
Mantenedores costumam responder em até 1 dia
@jong-kyung já está trabalhando nisso.
Desde 3/11/2026.
- #3329 de @voidzero-bot — fechado sem integrar
Avaliação
Esta issue ainda não foi avaliada.
Descrição
Problem
Vite+ selects Yarn behavior from the version in packageManager, which is the launcher it downloads. However, the launcher hands the command to the release in yarnPath unless ignorePath or YARN_IGNORE_PATH disables that delegation. When the two versions differ, Vite+ makes its decision for a version that does not run the command.
The most serious result is a silent false success. With packageManager: "[email protected]" and yarnPath pointing to Yarn 3.8.7, vp unlink prints a warning and exits with code 0, but the portal: resolution stays in package.json. Running the same launcher directly removes it. This was found in the review of #3286.
Reproduction
These steps need the unlink gate from #3286.
- Set
"packageManager": "[email protected]"inpackage.json. - Copy
bin/yarn.jsfrom@yarnpkg/[email protected]to.yarn/releases/yarn-3.8.7.cjs. - Create
.yarnrc.ymlwithnodeLinker: node-modulesandyarnPath: .yarn/releases/yarn-3.8.7.cjs. - Run
vp install. - Create
../linked-lib/package.jsonwith the namelinked-lib, then runvp link ../linked-lib. - Run
vp unlink linked-lib.
Expected: Yarn 3 removes the linked-lib resolution from package.json.
Actual: Vite+ prints this warning and exits with code 0, and the resolution stays.
warn: yarn unlink requires Yarn Classic or yarn >= 3.0.0. Skipping.
Affected checks
| Result of a mismatch | Checks | Launcher and effective version | Source |
|---|---|---|---|
| Skips a supported command | unlink, patch-commit --save (Yarn 3) |
2.x and 3 or later | #3286 |
| Skips a supported command | audit (Yarn 2.4) |
Below 2.4 and 2.4 or later | #3286 |
| Skips a supported command | patch, patch-commit, rebuild, whoami |
Classic and Berry | main |
| Skips a supported command | list, licenses, team |
Berry and Classic | main |
| Falls back to npm | stage (Yarn 4.16) |
Below 4.16 and 4.16 or later | main |
| Rejects a supported option | not_supported(yarn ...) rules with version conditions |
Depends on the rule | Mostly main |
| Builds arguments for the wrong Yarn family | is_berry() branches |
Classic and Berry | main |
| Sends a setting the effective Yarn rejects | YARN_ENABLE_TIPS in resolve_for_manager |
4.x and 2.x or 3.x | main |
This table comes from reading the code. Only the Yarn 2 launcher delegating to Yarn 3 has been reproduced end to end. The Classic and Berry rows, and whether the Classic launcher delegates in the same way, still need to be confirmed.
Possible direction
An earlier attempt in #3286 (eb4b2c713) ran yarn --version before every Yarn command. It is accurate because Yarn applies its own configuration rules, but it adds a process to every command.
A cheaper option is to resolve with the launcher version first and query the effective version only when Vite+ declines the request, which means a Noop, an InvalidArgument, or a FallbackCommand diagnostic. If the query reports a different version, Vite+ resolves again. Commands that run need no query because Yarn reports its own errors.
This option would not fix the is_berry() argument branches or YARN_ENABLE_TIPS, because those affect commands that do run. Reading the version from the yarnPath file name avoids a process, but the name can be arbitrary, and it would not account for parent or home configuration files or environment overrides.
- Linguagem predominante
- Rust
- Estrelas
- 6.5k
- Forks
- 297
- Merge médio
- 1d 3h
- PRs com merge (30d)
- 245
Preparar o ambiente
Inicia o contêiner de desenvolvimento do projeto no navegador, com a sua própria conta do GitHub.
- Sem Dockerfile nem arquivo Docker Compose
- Sem modelo de pull request
- Ler o guia de contribuição
Primeiros passos
- Leia a issue inteira e depois o guia de contribuição do projeto.
- Comente na issue dizendo que vai assumir — evita que duas pessoas façam o mesmo trabalho.
- Faça um fork do repositório e trabalhe em uma branch.
- Abra um pull request que referencie o número da issue.
Mais de voidzero-dev/vite-plus
-
triage: failed
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 71/100
voidzero-dev/vite-plus#3360 · 2 comentários ·
Mantenedores costumam responder em até 1 dia
-
triage: not actionable
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 85/100
voidzero-dev/vite-plus#3296 · 1 comentário · 1 reação ·
Mantenedores costumam responder em até 1 dia
-
pending triage
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 63/100
voidzero-dev/vite-plus#3235 ·
Mantenedores costumam responder em até 1 dia
-
Docker guide: the runtime stage needs libatomic1 for Node.js 25 and laterTalvez já em andamento @kshanxs assumiu há 12 dias. Abertadocumentation
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 84/100
voidzero-dev/vite-plus#3219 · 2 comentários · 1 reação ·
Mantenedores costumam responder em até 1 dia
-
pending triage
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 72/100
voidzero-dev/vite-plus#2882 · 2 comentários ·
Mantenedores costumam responder em até 1 dia
Todas as issues de voidzero-dev/vite-plus
Issues semelhantes
-
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 85/100
Mantenedores costumam responder em até 1 dia
-
bug i18n priority: medium ui
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 65/100
storytold/craft-anything#983 · 1 comentário ·
Mantenedores costumam responder em até 1 dia
-
needs triage
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 72/100
pbakaus/impeccable#1328 ·
Mantenedores costumam responder em até 1 dia
-
`swf` upgrade to 0.4.0Aberta
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 66/100
Dinnerbone/Rascal#91 · 2 reações ·
-
Dificuldade 2/5 1-3 horas Facilidade para iniciantes 76/100
higress-group/HiRoute#405 ·
Mantenedores costumam responder em até 1 dia