False positive: CVE-2023-29019 (@fastify/passport) reported against npm package passport 0.7.0

オープン
#23,692 コメント 3 件 リアクション 0 件 担当者 2 名 GitHub で見る

メンテナーはふだん 1 日以内に返信

@Molter73 がすでに取り組んでいます。

2026年11月3日 から。

評価

この issue はまだ評価されていません。

説明

RHACS image scanning reports CVE-2023-29019 against the npm package passport version 0.7.0, but this CVE affects a different package.

What RHACS reports

Fixable CVE-2023-29019 (CVSS 8.1) (severity Important) found in component 'passport' (version 0.7.0), resolved by version 1.1.0

Why this is a false positive

  1. CVE-2023-29019 affects only @fastify/passport, with vulnerable ranges < 1.1.0 and >= 2.0.0, < 2.3.0. The fixed versions are 1.1.0 and 2.3.0, and that is where the "resolved by version 1.1.0" in the finding comes from.
    a. https://github.com/advisories/GHSA-4m3m-ppvx-xgw9
    b. https://github.com/fastify/fastify-passport/security/advisories/GHSA-4m3m-ppvx-xgw9
  2. passport 1.1.0 does not exist. The latest published version of passport is 0.7.0: https://www.npmjs.com/package/passport?activeTab=versions
  3. The only advisory for passport itself (CVE-2022-25896, GHSA-v923-w3x8-wh69) affects versions < 0.6.0, so 0.7.0 is already fixed: https://github.com/advisories/GHSA-v923-w3x8-wh69
  4. The image has no @fastify/passport in it. passport 0.7.0 is a transitive dependency of Strapi 5.31.2: @strapi/admin → [email protected] → [email protected].

It looks like the vulnerability matcher ties the advisory to the package by its unscoped name (passport) and ignores the npm scope (@fastify/). If so, other scoped npm packages whose unscoped names collide with popular packages could get the same kind of false positive.

Environment

  • Scan method: roxctl image check in CI
  • Image contents: Node.js application (Strapi 5.31.2), npm dependencies from package-lock.json

To reproduce

  1. Build any Node.js image whose node_modules contains [email protected] and no @fastify/passport. A minimal package.json with "passport": "0.7.0" is enough.
  2. Scan it with RHACS (roxctl image scan or roxctl image check).
  3. CVE-2023-29019 is reported against passport 0.7.0.

Expected: CVE-2023-29019 is not reported for passport. It should be reported only for @fastify/passport in the affected ranges.

Request: please correct the package matching for this advisory, and if possible check whether other scoped npm advisories are affected the same way. In the meantime, could you confirm the recommended way to suppress this finding? Our plan is a CVE deferral/exception scoped to the passport component.

Thank you

主要言語
Go
スター
1.3k
フォーク
194
平均マージ
2日 20時間
マージ済み PR(30日)
392

環境構築

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

stackrox/stackrox のほかの issue

stackrox/stackrox の issue をすべて見る

似ている issue

Go の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。