Hacktoberfest 2026:メンテナが10月に向けて印を付けた、オープンで初心者向けの issue。 Hacktoberfest の issue を見る

python-caldav/caldav は初心者に優しい?

python-caldav/caldav のメンテナーはふだん 1 日以内に PR へ返信します。 初心者向けの issue が現在 1 件オープンです。

スター
412
フォーク
113
オープンの初心者向け issue
1
索引済み issue
63
平均マージ
1日 2時間
マージ済み PR(30日)
41
主要言語
Python
ライセンス
Apache-2.0
最終 GitHub push
2026年10月6日
最新の索引
2026年10月6日
コントリビューションガイド
コントリビューションガイド
行動規範
行動規範
初心者向けラベル
help wanted

python-caldav/caldav にコントリビュートするには

  1. まずコントリビューションガイドを読みましょう。変更の提案、テスト、レビューの進め方が書かれています。
  2. 行動規範も読んでおきましょう。チャットだけでなく issue や PR にも適用されます。
  3. あなたのコントリビュートはプロジェクトの Apache-2.0 ライセンスで公開されます。
  4. 下にある初心者向けのオープンな issue を選び、作業を始める前に取り組みたいとコメントしましょう。
issue を読み込んでいます

誰かが対応中かもしれないイシューは最後に並べています。 すべて日付順に表示

  • Apply vcal.fix() fixups on save, not only on load
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    python-caldav/caldav#774 ·

    メンテナーはふだん 1 日以内に返信

  • Collation: accent-insensitive and locale-aware searches must be decided client-side
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    python-caldav/caldav#769 ·

    メンテナーはふだん 1 日以内に返信

  • complete(handle_rrule=True) fails with ScheduleTagMismatchError, leaving a half-completed recurring task
    オープン

    難易度 3/5 半日 初心者へのやさしさ 50/100

    python-caldav/caldav#765 ·

    メンテナーはふだん 1 日以内に返信

  • Keep the server's raw bytes, and allow sending given bytes unchanged
    オープン
    enhancement

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    python-caldav/caldav#763 ·

    メンテナーはふだん 1 日以内に返信

  • Know when icalendar_instance was modified
    オープン
    enhancement

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#761 ·

    メンテナーはふだん 1 日以内に返信

  • Tests: It's needed with some test-runs without `features` configured
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    python-caldav/caldav#725 ·

    メンテナーはふだん 1 日以内に返信

  • Test the library properly with Yahoo
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 48/100

    python-caldav/caldav#720 ·

    メンテナーはふだん 1 日以内に返信

  • Configuration: allow password-yielding commands in config file.
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 30/100

    python-caldav/caldav#704 ·

    メンテナーはふだん 1 日以内に返信

  • Extended MKCOL (RFC 5689): detection, testing and 207 handling
    オープン
    enhancement roadmap

    難易度 4/5 3〜5日 初心者へのやさしさ 45/100

    python-caldav/caldav#702 ·

    メンテナーはふだん 1 日以内に返信

  • Support calendar sharing (draft-pot-caldav-sharing)
    オープン
    enhancement roadmap

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#701 ·

    メンテナーはふだん 1 日以内に返信

  • Support managed attachments (RFC 8607)
    オープン
    enhancement roadmap

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#700 ·

    メンテナーはふだん 1 日以内に返信

  • Implement WebDAV ACL operations on calendars (RFC 3744)
    オープン
    enhancement roadmap

    難易度 5/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#699 ·

    メンテナーはふだん 1 日以内に返信

  • Parse server iCalendar through vcal.parse_ical() consistently
    オープン
    refactoring

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    python-caldav/caldav#698 ·

    メンテナーはふだん 1 日以内に返信

  • Rate-limit handling to count requests
    オープン
    enhancement

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    python-caldav/caldav#697 ·

    メンテナーはふだん 1 日以内に返信

  • Sync mode support for the httpx family
    オープン
    enhancement

    難易度 5/5 1週間以上 初心者へのやさしさ 32/100

    python-caldav/caldav#696 ·

    メンテナーはふだん 1 日以内に返信

  • Retries on connection failures and on a closed idle keep-alive connection
    オープン
    enhancement

    難易度 4/5 3〜5日 初心者へのやさしさ 38/100

    python-caldav/caldav#695 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • require_tls only enforced on RFC 6764 discovery, not on explicit URLs
    オープン

    難易度 2/5 1〜3時間 初心者へのやさしさ 62/100

    python-caldav/caldav#687 ·

    メンテナーはふだん 1 日以内に返信

  • AssertionError ("Deviation from expectations found") when using Infomaniak CalDAV with Home Assistant Container
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 38/100

    python-caldav/caldav#684 · コメント 5 件 ·

    メンテナーはふだん 1 日以内に返信

  • WebDAV Push support
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 30/100

    python-caldav/caldav#674 · コメント 4 件 ·

    メンテナーはふだん 1 日以内に返信

  • Async refactoring: reduce code duplication
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 32/100

    python-caldav/caldav#665 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

  • "Protocol layer" cleanup
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#664 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • FeatureSet cleanup: simplify over-complex type-system remnants in compatibility_hints.py
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 45/100

    python-caldav/caldav#659 ·

    メンテナーはふだん 1 日以内に返信

  • Ruff ignore list is too long
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#634 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

  • GMX calendar creation not working very well
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    python-caldav/caldav#624 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • v4.0 - rip out all deprecated methods that yields deprecationwarning
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#619 ·

    メンテナーはふだん 1 日以内に返信

  • Auto-detection of server quirks
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 28/100

    python-caldav/caldav#600 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • Roadmap Updates
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    python-caldav/caldav#599 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

  • Intelligent deletion of single recurrences
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#598 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

  • Create helper methods for identifying various "recurrence states" for a CalendarObjectResource
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    python-caldav/caldav#597 ·

    メンテナーはふだん 1 日以内に返信

  • Refactor setup/teardown methods in the functional test setup
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#593 ·

    メンテナーはふだん 1 日以内に返信

  • Feature configuration subsystem: extra_features and include
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#592 ·

    メンテナーはふだん 1 日以内に返信

  • Remove the old incompatibility flags completely
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#585 ·

    メンテナーはふだん 1 日以内に返信

  • `tests/conf.py` is a mess
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    python-caldav/caldav#577 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • Support negated searches
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#568 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • Improved collation support for non-ascii case-insensitive text-match
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#567 · コメント 1 件 ·

    メンテナーはふだん 1 日以内に返信

  • Follow PROPFIND redirects
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#552 · コメント 3 件 ·

    メンテナーはふだん 1 日以内に返信

  • Searching also returns full-day events of adjacent days
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    python-caldav/caldav#545 · コメント 6 件 ·

    メンテナーはふだん 1 日以内に返信

  • Docs and example code: use the icalendar .new method
    オープン
    doc

    難易度 3/5 1〜2日 初心者へのやさしさ 42/100

    python-caldav/caldav#541 · コメント 3 件 ·

    メンテナーはふだん 1 日以内に返信

  • Find and kill instances of `event.component['uid']` et al
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 35/100

    python-caldav/caldav#515 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

  • Documentation howtos
    オープン
    doc

    難易度 3/5 1〜2日 初心者へのやさしさ 35/100

    python-caldav/caldav#513 ·

    メンテナーはふだん 1 日以内に返信

  • Support RFC 7953 Availability
    オープン
    enhancement

    難易度 3/5 1〜2日 初心者へのやさしさ 35/100

    python-caldav/caldav#425 ·

    メンテナーはふだん 1 日以内に返信

  • Improvements, test code and documentation needed for editing and selecting recurrence instances
    オープン
    doc

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    python-caldav/caldav#398 · コメント 4 件 ·

    メンテナーはふだん 1 日以内に返信

  • Collission avoidance
    オープン
    enhancement

    難易度 3/5 1〜2日 初心者へのやさしさ 45/100

    python-caldav/caldav#152 ·

    メンテナーはふだん 1 日以内に返信

  • Support for alarms
    オープン
    enhancement

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    python-caldav/caldav#132 · コメント 6 件 ·

    メンテナーはふだん 1 日以内に返信

  • Documentation for each server/cloud provider
    オープン
    doc enhancement

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    python-caldav/caldav#120 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

  • Increase test coverage
    オープン
    testing regime

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#93 · コメント 3 件 ·

    メンテナーはふだん 1 日以内に返信

  • Caldav test servers
    オープン
    help wanted roadmap testing regime

    難易度 5/5 1週間以上 初心者へのやさしさ 18/100

    python-caldav/caldav#45 · コメント 20 件 ·

    メンテナーはふだん 1 日以内に返信

  • v4.0 - requests, niquests, httpx or something else?
    対応中かも このイシューにリンクされたプルリクエストがオープン中、またはマージ済みです。 オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    python-caldav/caldav#611 · コメント 20 件 ·

    メンテナーはふだん 1 日以内に返信

  • DNSSEC validation for automatic service discovery
    対応中かも このイシューにリンクされたプルリクエストがオープン中、またはマージ済みです。 オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    python-caldav/caldav#571 ·

    メンテナーはふだん 1 日以内に返信

  • Refactoring - `get_duration`, `get_due`, `get_dtend` to be obsoleted
    対応中かも このイシューにリンクされたプルリクエストがオープン中、またはマージ済みです。 オープン
    deprecation

    難易度 3/5 半日 初心者へのやさしさ 55/100

    python-caldav/caldav#482 · コメント 2 件 ·

    メンテナーはふだん 1 日以内に返信

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。