This repository is a mirror of https://git.openwrt.org/?p=project/odhcpd.git. Pull requests will be accepted which will be merged in odhcpd.git

openwrt/odhcpd は初心者に優しい?

openwrt/odhcpd への外部コントリビューターの PR が最近は少なく、どのくらいマージされるかはまだ言えません。 初心者向けのオープンな issue は今はありません。下の一覧に、このリポジトリのほかの issue があります。

スター
204
フォーク
151
オープンの初心者向け issue
0
索引済み issue
66
主要言語
C
ライセンス
GPL-2.0
最終 GitHub push
2026年11月8日
最新の索引
2026年9月19日
コントリビューションガイド
コントリビューションガイドがありません
行動規範
行動規範がありません
初心者向けラベル
初心者向けラベルは索引されていません
PR マージ指標
30日以内にマージされた PR はありません

openwrt/odhcpd にコントリビュートするには

  1. コントリビューションガイドはないので、README と最近マージされた PR をいくつか読んで、変更の出し方をつかみましょう。
  2. あなたのコントリビュートはプロジェクトの GPL-2.0 ライセンスで公開されます。
  3. リポジトリをフォローすれば、新しい初心者向け issue が出たときにわかります。下のほかの issue も見てみましょう。
issue を読み込んでいます

誰かが対応中かもしれないイシューは最後に並べています。 すべて日付順に表示

  • Protect DHCPv6 static leases from SLAAC conflicts
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#431 ·

  • ndp: ETH_P_IPV6 socket misses locally generated WAN NS, preventing relay route discovery
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 42/100

    openwrt/odhcpd#429 ·

  • Q: How to prevent odhcpd from staleing the prefixes on PPPoE reconnect?
    オープン

    難易度 4/5 1〜2日 初心者へのやさしさ 35/100

    openwrt/odhcpd#427 ·

  • DHCPv6-PD Renew from a different link-local address does not update route next-hop
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 54/100

    openwrt/odhcpd#425 ·

  • Unbound lease synchronization can miss final state
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 55/100

    openwrt/odhcpd#422 · コメント 1 件 ·

  • Automatic RA MTU can remain at 1500 after LAN IPv6 MTU becomes 1492 with PPPoE/PD
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    openwrt/odhcpd#421 · コメント 1 件 ·

  • Announce all addresses of an interface when `dns_service` is set to true
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 68/100

    openwrt/odhcpd#417 ·

  • Confguration of RIOs (Route Information Options) not possible
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    openwrt/odhcpd#414 ·

  • dhcpv6 clients vulnerable to remote discovery via address scanning attacks with dhcpv6_hostidlength default of 12
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    openwrt/odhcpd#413 · コメント 2 件 ·

  • Axis network cameras no longer receive IPv6 address from odhcpd after update
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 45/100

    openwrt/odhcpd#411 · コメント 1 件 ·

  • Running as non-root or dropping linux capabilities
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#410 ·

  • rfc9096: br-lan: changed x-> y and piofile updated messages repeated in log
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 45/100

    openwrt/odhcpd#405 · コメント 1 件 ·

  • The lease file is lost upon service restart
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    openwrt/odhcpd#400 · コメント 1 件 ·

  • [Bug] Server sends malformed Relay-reply: Incorrect length for Relay Message (Option 9) causes parse errors on Relay Agent
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    openwrt/odhcpd#398 · コメント 1 件 ·

  • [Feature Request] Broadcast Lifetime=0 for RDNSS/DHCPv6 DNS when disabled to flush client cache
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 42/100

    openwrt/odhcpd#397 ·

  • Unsolicited RA interval not adjusted when lifetimes clamped to remaining WAN lifetime
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 45/100

    openwrt/odhcpd#395 · コメント 1 件 · リアクション 1 件 ·

  • Bug Report: RA not sent on LAN when log level is below 7 (odhcpd 2026.01.19)
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    openwrt/odhcpd#388 · コメント 4 件 · リアクション 4 件 ·

  • odhcpd: RFC 9096 piodir causes permanent stale prefix loop after wan reconnect, LAN devices only get ULA addresses
    再び着手できるかも @Noltari が 240 日前に担当しましたが、オープン中のプルリクエストはありません。 オープン
    bug

    openwrt/odhcpd#387 · コメント 5 件 · リアクション 1 件 · 担当者 1 名 ·

  • Extend `prefix_filter` to filter out unrelated prefixes in relay mode for RA, DHCPv6 and NDP
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#385 · コメント 1 件 ·

  • Feature Request: announce different encrypted DNS servers for static hosts to support NextDNS, AdGuard Home, and Control D
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#377 ·

  • Support option expandhosts or something equivalent
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    openwrt/odhcpd#370 ·

  • FR: dhcpv6: support RECONFIGURE incl. all needed infrastructure (RFC8415)
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 32/100

    openwrt/odhcpd#346 · コメント 10 件 ·

  • Add network to the DHCP section and specify a network segment as the DHCP address pool
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    openwrt/odhcpd#243 · コメント 1 件 ·

  • odhcp isn't able to start correctly when lan is in vlan filtering bridge
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#239 · コメント 3 件 ·

  • Enabling the Default router = Automatic option causes lock contention w/ bird2
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    openwrt/odhcpd#236 · コメント 1 件 ·

  • No IPv6 address when using static IPv6 address
    オープン
    bug

    難易度 4/5 3〜5日 初心者へのやさしさ 38/100

    openwrt/odhcpd#230 · コメント 17 件 · リアクション 1 件 ·

  • RA not sent for PD
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 28/100

    openwrt/odhcpd#222 · コメント 12 件 ·

  • Support a list of clients (IPv6 addresses) to advertise to
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 30/100

    openwrt/odhcpd#220 · コメント 11 件 · リアクション 6 件 ·

  • RA relay shouldn't relay link-local DNS
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 45/100

    openwrt/odhcpd#218 · コメント 3 件 ·

  • Optionally run DHCPv6 server on WAN interface when no IPv6 address Prefix is delegated from ISP
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    openwrt/odhcpd#216 · コメント 18 件 · リアクション 2 件 ·

  • Implement RFC 6939
    再び着手できるかも @stintel が 191 日前に担当しましたが、オープン中のプルリクエストはありません。 オープン
    feature request

    openwrt/odhcpd#215 · コメント 1 件 · 担当者 1 名 ·

  • Allow limiting prefixes more
    オープン

    難易度 3/5 1〜2日 初心者へのやさしさ 35/100

    openwrt/odhcpd#208 ·

  • DHCPv4 static leases per interface
    オープン
    feature request

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    openwrt/odhcpd#201 · リアクション 1 件 ·

  • NoPrefixAvail trying to request a /64 from a /48 PD
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    openwrt/odhcpd#180 · コメント 14 件 ·

  • odhcpd does not seem to respond to dynamicaly created interfaces such as ppp1 etc..
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    openwrt/odhcpd#167 · コメント 2 件 ·

  • Relayed RA causing wifi drops for LineageOS 17.1 Phones
    オープン
    bug

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    openwrt/odhcpd#166 · コメント 5 件 ·

  • auto assign for more than /64 prefix, subnet for /112
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    openwrt/odhcpd#164 · コメント 11 件 ·

  • Race condition between ULA and GUA on the same interface
    オープン
    bug

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#153 · コメント 12 件 ·

  • Advertise ipv6 routes from OpenVPN
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 35/100

    openwrt/odhcpd#152 · コメント 3 件 · リアクション 1 件 ·

  • issue with static address and IPv6 PD
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    openwrt/odhcpd#148 ·

  • if proxying against another proxying creating DAD when an entry might be needed.
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    openwrt/odhcpd#145 · コメント 1 件 ·

  • Rewrite prefix in NDP code to support NPTv6
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#144 · コメント 1 件 · リアクション 1 件 ·

  • Add system ip to hosts file (ipv6)
    オープン
    feature request

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#126 ·

  • Emulate dnsmasq tag feature, or allow per host DNS announce override
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    openwrt/odhcpd#109 · リアクション 1 件 ·

  • can i set WAN route preferences for hosts behind router?
    オープン
    question

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    openwrt/odhcpd#105 · コメント 3 件 ·

  • Enable Unicast Relay
    オープン
    feature request

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    openwrt/odhcpd#100 · コメント 2 件 ·

  • NDP relay not working because NDP proxy entries are not added
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#92 · コメント 8 件 · リアクション 9 件 ·

  • Ambiguity in router preference advertised in RA
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    openwrt/odhcpd#80 ·

  • Aftter assigning IA_PD, odhcp starts believing local interfaces lack public prefixes
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 38/100

    openwrt/odhcpd#79 · コメント 7 件 ·

  • Reconnect between router and client needed for global stateful DHCPv6 assignment.
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    openwrt/odhcpd#77 · コメント 1 件 ·

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。