Hacktoberfest 2026:メンテナが10月に向けて印を付けた、オープンで初心者向けの issue。 Hacktoberfest の issue を見る

change copySizeLimit to a value larger than the default `5242880000` not working

オープン
#700 コメント 1 件 リアクション 0 件 担当者 0 名 GitHub で見る

まだ誰も着手していません。

評価

難易度
3/5
見積もり時間
1〜2日
初心者へのやさしさ
35/100
issue の種類
バグ
明瞭さ
おおむね明確
活発さ
停滞
技術スタック
helm, kubernetes

調査の方向性

Nextcloud の copySizeLimit を設定する Helm chart template と、chart の values/configuration path を確認し、S3 backend がこの設定をどのように受け取るかを確認する。5 GB を超えるファイルで再現し、occ config:list system と upload の動作を確認する。values で 5242880000 を超える制限を、unknown error なしで設定できれば完了とする。

索引モデルが issue の本文から書いたものです。

説明

Describe your Issue

It's a common case that user could upload files that larger than 5GB, and when using s3 backend, it's limited by copySizeLimit parameter.

Logs and Errors

when uploading a file with 10GB, it finished uploading and report an unknown error.

Describe your Environment

  • Helm Chart Version: 6.6.4

  • values.yaml:
    there is no option that could be configured in chart values.
    instead, I modify the chart template directly and check the copySizeLimit to be taken into effect with occ config:list system command.

Additional context, if any

主要言語
Go Template
スター
536
フォーク
316
平均マージ
4日 16時間
マージ済み PR(30日)
2

環境構築

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

nextcloud/helm のほかの issue

nextcloud/helm の issue をすべて見る

似ている issue

Cloud の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。