Disable Alerts after 7 days?

オープン
#175 コメント 0 件 リアクション 0 件 担当者 0 名 GitHub で見る

まだ誰も着手していません。

評価

難易度
4/5
見積もり時間
3〜5日
初心者へのやさしさ
35/100
issue の種類
ドキュメント
明瞭さ
説明が足りない
活発さ
停滞
技術スタック
azure

調査の方向性

Azure Monitor のアラート ルール、7 日間の失敗による無効化、v1 ルールと v2 ルールの違いに関する issue の質問から始めます。関連する Azure Monitor のドキュメントを確認し、その動作が適用されるか、存在しないテーブルや列がどのように扱われるか、またそれを防止できるかを記録します。各質問に明確な文書化された回答があれば完了です。

索引モデルが issue の本文から書いたものです。

説明

I have a question related to behaviour as seen below.

We deploy about 300 alerts for our customers which are mostly based upon log searches.

I gave read that when an alert rule is failing for 7 days it gets disabled automatically.

As I understood the documentation this also happens when the syntax of the query is ok but if the table/column does not yet exist in log analytics.

Since we bootstrap our environments with all these alerts it could obviously be that a customer will not deploy all the resources that have an alert within a 7 day period. It could take months for somebody to actually deploy an AKS cluster for example.

Is the "7 day disable automation by MS" applicable to:

  • v1 and v2 alert rules

Is there a way to prevent this from happening?

Did I understand the mechanism correctly?

"alert 123 is disabled by the System due to : Alert has been failing consistently with the same exception for the past week"

主要言語
PowerShell
スター
1.2k
フォーク
493
PR マージ指標
30日以内にマージされた PR はありません

コントリビューションガイド

コントリビューションガイドを開く

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

microsoft/AzureMonitorCommunity のほかの issue

microsoft/AzureMonitorCommunity の issue をすべて見る

似ている issue

Cloud の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。