Hacktoberfest 2026:メンテナが10月に向けて印を付けた、オープンで初心者向けの issue。 Hacktoberfest の issue を見る

オーナー

索引済みのリポジトリ 1 件 · GitHub で見る

issue を読み込んでいます

誰かが対応中かもしれないイシューは最後に並べています。 すべて日付順に表示

  • `dtls_get_cookie`: dereference before the length check (currently masked by `dtls_create_cookie`)
    オープン

    難易度 2/5 1〜3時間 初心者へのやさしさ 68/100

    eclipse-tinydtls/tinydtls#279 · コメント 2 件 · リアクション 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • `MASK_L` over-shifts for RFC 3610-legal `L ≥ 4`, collapsing the CCM counter (keystream reuse at `L = 4`)
    オープン

    難易度 2/5 1〜3時間 初心者へのやさしさ 57/100

    eclipse-tinydtls/tinydtls#278 · コメント 3 件 · リアクション 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • ECDSA Verification Without On-Curve Check
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 45/100

    eclipse-tinydtls/tinydtls#274 · コメント 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • tinydtls Unbounded Handshake Reorder Queue DoS
    オープン
    bug

    難易度 4/5 3〜5日 初心者へのやさしさ 48/100

    eclipse-tinydtls/tinydtls#273 · コメント 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • tinydtls `dtls_update_parameters` Assert-Only Length Guard
    オープン

    難易度 3/5 半日 初心者へのやさしさ 48/100

    eclipse-tinydtls/tinydtls#272 · コメント 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • DTLS 1.2 (RFC 6347) Compliance Observations in tinydtls
    再び着手できるかも @boaks が 178 日前に担当しましたが、オープン中のプルリクエストはありません。 オープン
    bug good first issue

    eclipse-tinydtls/tinydtls#268 · コメント 2 件 · リアクション 1 件 · 担当者 1 名 ·

    メンテナーはふだん 2 日以内に返信

  • New tag / version
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    eclipse-tinydtls/tinydtls#261 · コメント 6 件 · リアクション 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • (Non-conformance) Stateless Cookie Exchange
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 35/100

    eclipse-tinydtls/tinydtls#259 · コメント 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • (Non-conformance) Wrapping of Record Sequence Number
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    eclipse-tinydtls/tinydtls#258 · コメント 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • Experiencing an extended handshake duration on a SAMR21-xpro device.
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    eclipse-tinydtls/tinydtls#224 · コメント 17 件 ·

    メンテナーはふだん 2 日以内に返信

  • RFC7250 - RawPublicKey - No Suitable Certificate?
    オープン
    enhancement

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    eclipse-tinydtls/tinydtls#186 · コメント 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • Issues for general cleanup?
    オープン
    question

    難易度 5/5 1週間以上 初心者へのやさしさ 20/100

    eclipse-tinydtls/tinydtls#143 · コメント 25 件 · リアクション 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • 32bit overflow does not work
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 30/100

    eclipse-tinydtls/tinydtls#125 · コメント 9 件 ·

    メンテナーはふだん 2 日以内に返信

  • Fuzzing Hello_Extensions?
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 20/100

    eclipse-tinydtls/tinydtls#65 · コメント 1 件 · リアクション 1 件 ·

    メンテナーはふだん 2 日以内に返信

  • Contact information to report a serious security vulnerablity
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 15/100

    eclipse-tinydtls/tinydtls#43 · コメント 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • Support for dtls connection id extension?
    オープン

    難易度 5/5 1週間以上 初心者へのやさしさ 15/100

    eclipse-tinydtls/tinydtls#27 · コメント 17 件 ·

    メンテナーはふだん 2 日以内に返信

  • Using retransmission timer
    オープン

    難易度 4/5 3〜5日 初心者へのやさしさ 25/100

    eclipse-tinydtls/tinydtls#26 · コメント 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • ECDHE_ECDSA ClientKeyExchange rejected as too short when DTLS_PSK_MAX_CLIENT_IDENTITY_LEN > 64
    対応中かも このイシューにリンクされたプルリクエストがオープン中、またはマージ済みです。 オープン
    bug good first issue please retest

    難易度 2/5 1〜3時間 初心者へのやさしさ 76/100

    eclipse-tinydtls/tinydtls#298 · コメント 2 件 ·

    メンテナーはふだん 2 日以内に返信

  • MSVC build is broken (undeclared `DTLS_DEBUG_BUF_SIZE`)
    対応中かも @mrdeep1 が 9 日前に担当しました。 オープン

    難易度 2/5 1〜3時間 初心者へのやさしさ 25/100

    eclipse-tinydtls/tinydtls#283 · コメント 5 件 ·

    メンテナーはふだん 2 日以内に返信

  • Server DoS vulnerability via malformed handshake sequence
    対応中かも このイシューにリンクされたプルリクエストがオープン中、またはマージ済みです。 オープン
    bug

    難易度 5/5 1週間以上 初心者へのやさしさ 25/100

    eclipse-tinydtls/tinydtls#244 · コメント 9 件 ·

    メンテナーはふだん 2 日以内に返信

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。