Hacktoberfest 2026:メンテナが10月に向けて印を付けた、オープンで初心者向けの issue。 Hacktoberfest の issue を見る

Dataset uploads fail with 413 in the single-node deployment

オープン 初心者向け
#8,720 コメント 0 件 リアクション 0 件 担当者 0 名 GitHub で見る

メンテナーはふだん 1 日以内に返信

まだ誰も着手していません。

評価

難易度
1/5
見積もり時間
1時間未満
初心者へのやさしさ
88/100
issue の種類
バグ
明瞭さ
明確に書かれている
活発さ
活発
技術スタック
docker-compose, nginx

調査の方向性

bin/single-node/nginx.conf から始め、そのアップロード処理を issue に記載されている multipart アップロードパスと比較します。single-node Docker Compose バンドルを実行し、1 MiB より大きいファイルが 413 応答なしで UI から正常にアップロードできることを確認します。同時に、既存の小さいファイルの動作が維持されていることも確認します。

索引モデルが issue の本文から書いたものです。

説明

What happened?

In the single-node Docker Compose deployment, uploading a file larger than 1 MiB through the UI fails with 413: bin/single-node/nginx.conf never setsclient_max_body_size, so nginx's 1 MiB default rejects multipart parts
(default 50 MiB) before they reach file-service.

How to reproduce?
  1. Deploy the single-node bundle (e.g. the official 1.2.0-incubating compose bundle): docker compose up
  2. Log in, create a dataset, and upload any file larger than 1 MiB through the UI
  3. The upload fails; DevTools shows POST /api/dataset/multipart-upload/part returning 413
  4. A file under 1 MiB uploads fine
Version/Branch

1.4.0-incubating-SNAPSHOT (main)

Commit Hash (Optional)

No response

What browsers are you seeing the problem on?

No response

Relevant log output

主要言語
Scala
スター
316
フォーク
189
平均マージ
4日 5時間
マージ済み PR(30日)
158

環境構築

はじめの一歩

  1. issue を最後まで読み、次にプロジェクトのコントリビューションガイドを読みます。
  2. 着手することを issue にコメントします — 二人が同じ作業をするのを防げます。
  3. リポジトリをフォークし、ブランチを切って変更します。
  4. issue 番号を参照したプルリクエストを送ります。

apache/texera のほかの issue

apache/texera の issue をすべて見る

似ている issue

Scala の issue をもっと見る

新しい issue をメールで受け取る

初心者向けの GitHub issue を短くまとめたダイジェスト。