Hacktoberfest 2026: le issue che i maintainer hanno segnato per ottobre, aperte e adatte ai principianti. Sfoglia le issue Hacktoberfest

Raise the setuptools build requirement to >=83 once Python <3.10 support is dropped

Aperta
#399 0 commenti 0 reazioni 0 assegnatari Vedi su GitHub

Nessuno ha ancora preso questa issue.

Valutazione

Difficoltà
3/5
Tempo stimato
1-2 giorni
Idoneità per principianti
25/100
Tipo di issue
Funzionalità
Chiarezza
Abbastanza chiara
Stato di attività
Attiva
Stack tecnologico
github-actions, python

Direzione di ricerca

Start with .github/dependabot.yml, pyproject.toml, and the Python 3.9 jobs in .github/workflows/tox.yml, .github/workflows/check_migrations_sqlite.yml, and .github/workflows/python-publish.yml. The issue sets the dependency and CI changes, but they depend on dropping Python 3.6–3.9 support first; check the requires-python floor before changing the build requirement. Done means Dependabot ignores setuptools major updates while Python below 3.10 is supported, then setuptools ≥83 and the listed CI workflows pass after the floor is raised.

Scritto dal modello di indicizzazione a partire dal testo della issue.

Descrizione

dependencies DEV: dev-ops TAG: dependencies

❌ This issue is not open for contribution. Visit Contributing guidelines to learn about the contributing process and how to find suitable issues.

Overview

Dependabot PR #347 raised the [build-system] requirement in pyproject.toml from setuptools>=64 to setuptools>=83.0.0, and was closed unmerged. setuptools 83 requires Python >=3.10, while morango declares requires-python = ">=3.6,<3.15", so the floor can only rise after morango drops Python 3.6–3.9.

Complexity: Low
Target branch: release-v0.9.x

Context
  • On #347, wheel builds on Python 3.9 could not resolve setuptools>=83.0.0, failing the "Python tests" and "Migrations for SQLite versions" workflows.
  • The package is built on Python 3.9 in .github/workflows/tox.yml, .github/workflows/check_migrations_sqlite.yml and .github/workflows/python-publish.yml.
  • Installing the sdist on Python 3.6–3.9 would also fail, since pip builds it in an isolated env that needs setuptools >=83.
The Change
  • Once Python <3.10 support is dropped, the build requirement should be setuptools>=83, with the three build jobs above running on Python >=3.10.
  • Until then, dependabot should stop proposing setuptools major versions.
Acceptance Criteria
  • .github/dependabot.yml ignores setuptools major updates while requires-python allows <3.10.
  • After requires-python is raised to >=3.10: [build-system] requires setuptools>=83, and the wheel builds and all test workflows pass in CI.

AI usage

rtibblesbot (Claude Code) reviewed #347 and drafted this issue from that review and the repository's build and CI config.

Filed from #347's review.

Lingua principale
Python
Stelle
15
Fork
23
Merge medio
3g 22h
PR unite (30g)
6

Preparare l'ambiente

Come iniziare

  1. Leggi tutta la issue e poi la guida ai contributi del progetto.
  2. Commenta sulla issue per dire che te ne occupi tu — evita che due persone facciano lo stesso lavoro.
  3. Fai un fork del repository e lavora su un branch.
  4. Apri una pull request che faccia riferimento al numero della issue.

Altre issue di learningequality/morango

Tutte le issue di learningequality/morango

Issue simili

Altre issue su Python

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.