Hacktoberfest 2026: le issue che i maintainer hanno segnato per ottobre, aperte e adatte ai principianti. Sfoglia le issue Hacktoberfest

`S3_ARCHIVE_CONFIG` without credentials causes startup failure.

Aperta
#247 0 commenti 2 reazioni 0 assegnatari Vedi su GitHub

Nessuno ha ancora preso questa issue.

Valutazione

Difficoltà
3/5
Tempo stimato
1-2 giorni
Idoneità per principianti
38/100
Tipo di issue
Bug
Chiarezza
Abbastanza chiara
Stato di attività
Ferma
Stack tecnologico
aws, go
Ambito
backend, cloud

Direzione di ricerca

Inizia individuando l'inizializzazione dell'avvio che gestisce S3_ARCHIVE_CONFIG e la configurazione delle credenziali dell'AWS SDK. Riproduci l'avvio con un URL privo di credenziali, quindi verifica che le credenziali della catena dinamica dell'SDK consentano di completare l'inizializzazione.

Scritto dal modello di indicizzazione a partire dal testo della issue.

Descrizione

When initializing, if S3_ARCHIVE_CONFIG is set to a URL which does not contain credentials, the machine will fail to start.

When using dynamically provisioned credentials such as via an OIDC-based IdP or EC2 instance profile; then no credentials will be present in the URL and the AWS SDK's credential-chain lookup should resolve the credentials.

Lingua principale
Go
Stelle
171
Fork
76
Merge medio
1h 19m
PR unite (30g)
1

Guida per i contributori

Nessuna guida per i contributori indicizzata per questo repository

Come iniziare

  1. Leggi tutta la issue e poi la guida ai contributi del progetto.
  2. Commenta sulla issue per dire che te ne occupi tu — evita che due persone facciano lo stesso lavoro.
  3. Fai un fork del repository e lavora su un branch.
  4. Apri una pull request che faccia riferimento al numero della issue.

Altre issue di fly-apps/postgres-flex

Tutte le issue di fly-apps/postgres-flex

Issue simili

Altre issue su Go

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.