Hacktoberfest 2026: le issue che i maintainer hanno segnato per ottobre, aperte e adatte ai principianti. Sfoglia le issue Hacktoberfest

Microsoft Security Advisory CVE-2026-26143: Microsoft PowerShell Security Feature Bypass Vulnerability

Aperta
#82 0 commenti 0 reazioni 0 assegnatari Vedi su GitHub

Nessuno ha ancora preso questa issue.

Valutazione

Difficoltà
3/5
Tempo stimato
Mezza giornata
Idoneità per principianti
8/100
Tipo di issue
Bug
Chiarezza
Da chiarire
Stato di attività
Ferma
Stack tecnologico
shell
Ambito
security

Direzione di ricerca

This is a published security advisory with no requested code change, and the fix belongs to the PowerShell/PowerShell repository, not this one. Read the affected-versions table and the note on -SkipLimitCheck with Import-PowerShellDataFile, then check the installed version with pwsh -v. Done means confirming which versions are patched (7.4.14, 7.5.5, 7.6.0) and, if you want to contribute, opening a question on the linked support path.

Scritto dal modello di indicizzazione a partire dal testo della issue.

Descrizione

PowerShell Security

Microsoft Security Advisory CVE-2026-26143: Microsoft PowerShell Security Feature Bypass Vulnerability

Executive Summary

Improper input validation in Microsoft PowerShell allows an unauthorized attacker to bypass a security feature locally.

System administrators are advised to update PowerShell 7 to an unaffected version (see affected software).

Discussion

Please open a support question to discuss the PowerShell aspects of this advisory.

Mitigation factors

What kind of security feature could be bypassed by successfully exploiting this vulnerability?

Exploiting this vulnerability bypasses dynamic-expression security checks which may lead to arbitrary code execution when then -SkipLimitCheck is used with Import-PowerShellDataFile. If you do not use the -SkipLimitCheck switch, you are not affected.

Affected Software

The vulnerability affects PowerShell 7 prior to the following versions:

PowerShell 7 Version Affected version Patched Version
7.6 <7.6.0 7.6.0
7.5 <7.5.5 7.5.5
7.4 <7.4.14 7.4.14

The vulnerability affects PowerShell when running on the following operating systems:

Operating System Affected
Windows Yes
macOS Yes
Linux Yes

Advisory FAQ

How do I know if I am affected?

If all of the following are true:

  1. Run pwsh -v, then, check the version in the table in Affected Software to see if your version of PowerShell 7 is affected.
How do I update to an unaffected version?

Follow the instructions at Installing PowerShell 7 to install the latest version of PowerShell 7.

Updating PowerShell 7 using Microsoft Update

Updating PowerShell 7 using Microsoft Update

Other Information

Reporting Security Issues

If you have found a potential security issue in PowerShell 7,
please email details to [email protected].

Support

You can ask questions about this issue on GitHub in the PowerShell organization.
This is located at https://github.com/PowerShell/.
The Announcements repo (https://github.com/PowerShell/Announcements)
will contain this bulletin as an issue and will include a link to a discussion issue where you can ask questions.

Disclaimer

The information provided in this advisory is provided "as is" without warranty of any kind. Microsoft disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall Microsoft Corporation or its suppliers be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages, even if Microsoft Corporation or its suppliers have been advised of the possibility of such damages. Some states do not allow the exclusion or limitation of liability for consequential or incidental damages so the foregoing limitation may not apply.

What if the update breaks my script or module?

You can uninstall the newer version of PowerShell 7 and install the previous version of PowerShell 7.
This should be treated as a temporary measure.
Therefore, the script or module should be updated to work with the patched version of PowerShell 7.

Acknowledgments

Microsoft recognizes the efforts of those in the security community who help us protect customers through coordinated vulnerability disclosure.

See acknowledgments for more information.

External Links

CVE-2026-26143

Revisions

V1.0 (April 14, 2026): Advisory published.

Version 1.0
Last Updated 2026-04-14

Lingua principale
Nessun dato sulla lingua
Stelle
20
Fork
8
Metriche di merge delle PR
Nessuna PR unita negli ultimi 30g

Preparare l'ambiente

Come iniziare

  1. Leggi tutta la issue e poi la guida ai contributi del progetto.
  2. Commenta sulla issue per dire che te ne occupi tu — evita che due persone facciano lo stesso lavoro.
  3. Fai un fork del repository e lavora su un branch.
  4. Apri una pull request che faccia riferimento al numero della issue.

Altre issue di PowerShell/Announcements

Tutte le issue di PowerShell/Announcements

Issue simili

Altre issue su Security

Ricevi le nuove issue nella tua casella

Un breve riepilogo di issue GitHub adatte ai principianti.