Upgrade google-cloud-error-reporting to 1.16 and google-cloud-logging to 3.x

Abierto
#6,376 0 comentarios 0 reacciones 0 asignados Ver en GitHub

Los mantenedores suelen responder en 1 día

Nadie ha tomado este issue todavía.

Evaluación

Dificultad
4/5
Tiempo estimado
1-2 días
Aptitud para principiantes
25/100
Tipo de issue
Refactorización
Claridad
Bien especificado
Estado de actividad
Activo
Stack tecnológico
google-cloud, python

Línea de trabajo

Start with requirements.in and the ErrorReportingMiddleware in contentcuration/contentcuration/middleware/error_reporting.py, then recompile requirements.txt. The issue says CI cannot exercise this path, so follow its instructions to configure the credentials and raise an unhandled view exception. Done means both package pins meet the acceptance criteria, the middleware client starts without error, and the exception appears in Google Cloud Error Reporting; the issue explicitly says it is not open for contribution.

Escrito por el modelo de indexación a partir del texto del issue.

Descripción

dependencies DEV: backend python

❌ This issue is not open for contribution. Visit Contributing guidelines to learn about the contributing process and how to find suitable issues.

Overview

Dependabot PR #6122 bumped google-cloud-error-reporting from 1.4.0 to 1.16.0, which pulls google-cloud-logging from 2.7.1 to 3.16.0 and adds opentelemetry-api==1.44.0. It was closed unmerged because CI never runs the code that uses these packages: ErrorReportingMiddleware loads only when GCLOUD_ERROR_REPORTING is set and needs service-account credentials.

Complexity: Low
Target branch: unstable

Context
  • ErrorReportingMiddleware calls error_reporting.Client.from_service_account_json(..., _use_grpc=False) and report_exception().
  • With _use_grpc=False, 1.16 reports through google.cloud.logging.Client, so the logging 2.x → 3.x major bump sits on this path.
  • google-cloud-error-reporting and google-cloud-logging move in lockstep: 1.16.0 requires google-cloud-logging>=3.9.0,<4.0.0.
  • Both 1.16.0 and logging 3.16.0 require Python ≥3.10; Studio runs 3.10.
The Change
  • Studio should run both packages at their current releases, recompiled from requirements.in.
  • The upgrade should be verified on the live error path, since CI cannot exercise it.
How to Get There
  • Set GCLOUD_ERROR_REPORTING, GOOGLE_APPLICATION_CREDENTIALS (a service-account JSON) and GCLOUD_DEBUGGER_APP_IDENTIFIER.
  • Raise an unhandled exception in any view.
Acceptance Criteria
  • requirements.txt pins google-cloud-error-reporting==1.16.x and google-cloud-logging==3.x.
  • With real credentials, the middleware's client is constructed at startup without error.
  • An unhandled view exception appears in Google Cloud Error Reporting under the GCLOUD_DEBUGGER_APP_IDENTIFIER service.

AI usage

rtibblesbot (Claude Code) reviewed #6122 and drafted this issue from that review and the 1.16.0 / 3.16.0 package metadata.

Filed from #6122's review.

Lenguaje dominante
Python
Estrellas
211
Forks
317
Merge medio
4 d 2 h
PR fusionados (30 d)
23

Preparar el entorno

Primeros pasos

  1. Lee el issue completo y luego la guía de contribución del proyecto.
  2. Comenta en el issue que vas a ocuparte — evita que dos personas hagan lo mismo.
  3. Haz un fork del repositorio y trabaja en una rama.
  4. Abre un pull request que haga referencia al número del issue.

Más de learningequality/studio

Todos los issues de learningequality/studio

Issues similares

Más issues de Python

Recibe los nuevos issues en tu correo

Un resumen breve de issues de GitHub para principiantes.