服务正常运行过程中部分接口出现locate path failed, status:Not Found异常导致请求404异常
Nadie ha tomado este issue todavía.
Evaluación
- Dificultad
- 5/5
- Tiempo estimado
- Más de una semana
- Aptitud para principiantes
- 25/100
- Tipo de issue
- Error
- Claridad
- Necesita aclaración
- Estado de actividad
- Estancado
- Stack tecnológico
- java
- Área
- api, backend, distributed-systems
Línea de trabajo
Comienza con el log adjunto y la ruta de inicialización del servicio RestOperationMeta mencionada en el issue. Rastrea por qué un servicio en ejecución puede informar locate path failed y devolver 404 después de la inicialización, y documenta una causa reproducible o las pruebas adicionales necesarias para aislarla.
Escrito por el modelo de indexación a partir del texto del issue.
Descripción
服务正常运行过程中部分接口出现locate path failed, status:Not Found异常导致4040异常,源码发现RestOperationMeta为服务初始化加载,未发现修改的地方,目前还未定位到根因,麻烦帮忙提供下定位方向及定位思路,日志如下
- Lenguaje dominante
- Java
- Estrellas
- 1.9k
- Forks
- 813
- Merge medio
- 8 d 23 h
- PR fusionados (30 d)
- 1
Guía de contribución
No hay ninguna guía de contribución indexada para este repositorio
Primeros pasos
- Lee el issue completo y luego la guía de contribución del proyecto.
- Comenta en el issue que vas a ocuparte — evita que dos personas hagan lo mismo.
- Haz un fork del repositorio y trabaja en una rama.
- Abre un pull request que haga referencia al número del issue.
Más de apache/servicecomb-java-chassis
-
bug
Dificultad 2/5 1-3 horas Aptitud para principiantes 65/100
apache/servicecomb-java-chassis#5106 ·
-
question
Dificultad 5/5 Más de una semana Aptitud para principiantes 35/100
apache/servicecomb-java-chassis#5153 · 1 comentario ·
-
[QUESTION] - 请发布3.x的最新版本 Abiertoquestion
Dificultad 4/5 3-5 días Aptitud para principiantes 25/100
apache/servicecomb-java-chassis#5146 ·
-
[FEATURE] - When will ServiceComb support Spring Boot 4.x, Spring Framework 7.x, and Jackson 3.x? Abiertoenhancement
Dificultad 5/5 Más de una semana Aptitud para principiantes 25/100
apache/servicecomb-java-chassis#5145 ·
-
2.x bug
apache/servicecomb-java-chassis#5141 · 1 asignado ·
Todos los issues de apache/servicecomb-java-chassis
Issues similares
-
executions.Query — startDate and timeRange filters are sent with inverted comparison operators Abiertoarea/plugin
Dificultad 2/5 1-3 horas Aptitud para principiantes 75/100
kestra-io/plugin-kestra#190 ·
-
litertlm-android AAR ships no consumer ProGuard rules → "mid == null" SIGABRT in minified apps Abierto
Dificultad 2/5 1-3 horas Aptitud para principiantes 70/100
google-ai-edge/LiteRT-LM#3739 ·
-
bug
Dificultad 2/5 1-3 horas Aptitud para principiantes 75/100
-
Add canonical URLs and a sitemap Abierto
Dificultad 2/5 1-3 horas Aptitud para principiantes 75/100
integra-team-red/meet-map#249 ·
-
[Studio][Bug] Cancelled create-user dialog keeps the password and admin switch for the next attempt Abierto
Dificultad 2/5 1-3 horas Aptitud para principiantes 75/100
apache/rocketmq-dashboard#5064 ·