Domains under new gTLDs such as as .blog are rejected with "invalid domain" error

Open
#48 1 comment 1 reaction 1 assignee View on GitHub

@nabla-c0d3 is already working on this.

Since Mar 17, 2019.

Assessment

This issue has not been assessed yet.

Description

bug

I performed all the steps in the documentation. I received a CA certificate for the application and included it in the application with custom SSLSocketFactory. However, I always get this error "Tried to pin unvalid domain". Where am I making a mistake?

network_security_config.xml

https://paste.ee/p/Hrj3E


CategoryFragment.java

https://paste.ee/p/Cd4To


MyApplication.java (only added TrustKit.initializeWithNetworkSecurityConfiguration(this);)

https://paste.ee/p/kx8Vo


and MyCustomSSLFactory.java

https://paste.ee/p/nlDhn

Dominant language
Java
Stars
604
Forks
90
Avg merge
1h 29m
Merged PRs (30d)
2

Contributor guide

No contributing guide indexed for this repository

First steps

  1. Read the whole issue, then the project's contributing guide.
  2. Comment on the issue to say you are picking it up — it saves two people doing the same work.
  3. Fork the repository and make your change on a branch.
  4. Open a pull request that references the issue number.

More from datatheorem/TrustKit-Android

All issues in datatheorem/TrustKit-Android

Similar issues

More Java issues

Get new issues in your inbox

A short digest of beginner-friendly GitHub issues.