Domains under new gTLDs such as as .blog are rejected with "invalid domain" error
@nabla-c0d3 is already working on this.
Since Mar 17, 2019.
Assessment
This issue has not been assessed yet.
Description
I performed all the steps in the documentation. I received a CA certificate for the application and included it in the application with custom SSLSocketFactory. However, I always get this error "Tried to pin unvalid domain". Where am I making a mistake?
network_security_config.xml
CategoryFragment.java
MyApplication.java (only added TrustKit.initializeWithNetworkSecurityConfiguration(this);)
and MyCustomSSLFactory.java
- Dominant language
- Java
- Stars
- 604
- Forks
- 90
- Avg merge
- 1h 29m
- Merged PRs (30d)
- 2
Contributor guide
No contributing guide indexed for this repository
First steps
- Read the whole issue, then the project's contributing guide.
- Comment on the issue to say you are picking it up — it saves two people doing the same work.
- Fork the repository and make your change on a branch.
- Open a pull request that references the issue number.
More from datatheorem/TrustKit-Android
-
Difficulty 5/5 Over a week Newbie friendliness 20/100
-
Difficulty 4/5 3-5 days Newbie friendliness 18/100
-
Difficulty 4/5 3-5 days Newbie friendliness 35/100
datatheorem/TrustKit-Android#93 · 3 comments ·
-
Difficulty 3/5 1-2 days Newbie friendliness 30/100
-
Difficulty 4/5 3-5 days Newbie friendliness 32/100
datatheorem/TrustKit-Android#91 · 4 comments ·
All issues in datatheorem/TrustKit-Android
Similar issues
-
Difficulty 2/5 1-3 hours Newbie friendliness 82/100
infinispan/infinispan#18150 ·
-
area/frontend
Difficulty 2/5 1-3 hours Newbie friendliness 65/100
-
Difficulty 2/5 1-3 hours Newbie friendliness 84/100
-
untriaged
Difficulty 2/5 1-3 hours Newbie friendliness 82/100
opensearch-project/k-NN#3597 ·
-
bug
Difficulty 2/5 1-3 hours Newbie friendliness 88/100