python runtime >= 3.11 required

Open
#773 0 comments 0 reactions 0 assignees View on GitHub

Maintainers usually reply within 1 day

Nobody has claimed this yet.

Assessment

Difficulty
1/5
Estimated time
Under an hour
Newbie friendliness
55/100
Issue type
Documentation
Clarity
Clearly specified
Activity status
Stale
Tech stack
aws, python

Research direction

Open the manual instructions linked in the issue under aws/logs_monitoring and find the text directing users to create a Python 3.10 Lambda function. Update that instruction to require Python 3.11, then review the same section to ensure the runtime guidance is consistent.

Written by the indexing model from the issue text.

Description

Describe what happened:

The instruction Create a Python 3.10 Lambda function using aws-dd-forwarder-.zip from the latest releases breaks the Lambda function. When we upgraded from Python 3.8, we also upgraded our function to version 3.108, layer version 48.

You must use runtime python 3.11. If you don't the lambda function errors with cannot load module 'lambda_function'

Describe what you expected:

Just need to get the documentation updated to say to use the python 3.11 runtime.

Dominant language
Python
Stars
351
Forks
397
Avg merge
6h 13m
Merged PRs (30d)
31

Getting set up

First steps

  1. Read the whole issue, then the project's contributing guide.
  2. Comment on the issue to say you are picking it up — it saves two people doing the same work.
  3. Fork the repository and make your change on a branch.
  4. Open a pull request that references the issue number.

More from DataDog/datadog-serverless-functions

All issues in DataDog/datadog-serverless-functions

Similar issues

More Python issues

Get new issues in your inbox

A short digest of beginner-friendly GitHub issues.