Sanity check for /etc/hosts does not consider same hostname alias in different domain

Open
#77 2 comments 0 reactions 1 assignee View on GitHub

Nobody has claimed this yet.

Assessment

This issue has not been assessed yet.

Description

bug
  1. Consider primary to be myserver.domainA and secondary to be myserver.domainB. Hostname is same but domain name is different.

  2. If we run replicate without wanting to use wildcard grants (which is the default), the replicate fails with error:

The HA servers share a common hostname or alias 'myserver'. Please fix this and re-run.

  1. We need to bypass this check if they have same hostname but in different domain

  2. We may also have to move this check ahead of stopping the primary controller as it is already stopped by the time this check is encountered.

This is introduced in 3.27.4

@rnav1234

Dominant language
Shell
Stars
13
Forks
11
PR merge metrics
No merged PRs in 30d

Contributor guide

No contributing guide indexed for this repository

First steps

  1. Read the whole issue, then the project's contributing guide.
  2. Comment on the issue to say you are picking it up — it saves two people doing the same work.
  3. Fork the repository and make your change on a branch.
  4. Open a pull request that references the issue number.

More from Appdynamics/HA-toolkit

All issues in Appdynamics/HA-toolkit

Similar issues

More Shell/Bash issues

Get new issues in your inbox

A short digest of beginner-friendly GitHub issues.